Finally found a fix for this problem I've been having all week. Figured I'd save folks out there a ton of headache. If you have MS Security Essentials installed, and notice it taking up a lot of your CPU performance (specifically "MsMpEng.exe process):

1. Run Task Manager, find the process with high CPU usage. (Sorting by CPU may help you find it)
Likely you will find "MsMpEng.exe" has taken much of your CPU time

2. Now go to your Microsoft Security Essentials, click on the "Settings" tab. Select "Excluded files and locations"
Browse to "C:\Program Files\Microsoft Security Client\MsMpEng.exe", Ok and press Add button to add the file to your list of excluded files and locations. Press Save changes button.

Credit to this blog for finding it.