#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Posts
    41
    Rep Power
    12

    Do I Have A php File Affecting Virus?


    Ok... Something really weird is going on. I was uploading files to my webpage when I accidentally hit delete on my images folder. It started deleting the images until I hit "stop" on the nav bar. Apparently, hitting stop just makes it delete the files fast or something, cuz there was no more "images" folder. So I was like, meh... whatever, I'll just upload them again.

    I did, and thrn tried going to my webpage at www.noahneiman.com and nothing came up. Just a blank page... That's funny... so I try uploaded my index.php file again and overwrite the one already there. Still, just gives me a blank page. That reallt weird, I think.

    I check my email a bit later for some reason and there's a returned email that is sent to me. But I don't remember sending anyone an email today... And it was addressed to some aol user ambwtabby@aol.com. It also had two attachements in it. One titled details.txt and another one I can't remember. I know I probably shouldn't have done this, but I opened them and there was some code in them. Nothing happened though. So I deleted the email off my computer.

    My webpage was still not working and even before I opened those attachments, there was a weirdly named .html file in my webpage files folder on my D: drive, where I keep all my webpage's files. when I went to delete it, it gave me an error and said that that file doesn't exist... again... weird. This was before I opened the email.

    So I try going to other pages in my domain and only the .html ones work now. All the php files won't load!!!

    Does anyone know what is wrong? I'm so worried because I worked really hard on all those pages and even hired someone to work on the php for me...
  2. #2
  3. Second highest poster :p
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jul 2001
    Posts
    7,322
    Rep Power
    33
    Viruses would not effect PHP files.

    The returned email is most likely from the MyDoom virus which fakes the email address that the email comes from.

    I think the returned email and the server problems are just a coincidence. I would contact whoever runs your server and get them to check the server.
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Posts
    41
    Rep Power
    12
    what does this MyDoom virus do? Should I format?
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Posts
    10
    Rep Power
    0

    mydoom removal tool


    You can download a removal tool for mydoom from any of the anti-virus sites - here's a link to the symantec security response page with tools to remove the virus:

    http://securityresponse.symantec.com/
    You can get full details of the virus and what it does from these sites.

    Don't Format anything!
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Posts
    41
    Rep Power
    12
    actually, I checked to see if I had MyDoom. I didn't. But my web hosting service says that there's nothing wrong with their servers. i don't know what the deal is...
  10. #6
  11. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Location
    Belfast sumwhere, although it could be Lisburn not too sure
    Posts
    178
    Rep Power
    12
    might be unlikely since you are using a hosting service, but you could have effected the permissions. ie you uploaded a new image folder with root permisions, making the files inaccessable to other files

    again i think it unlikely but it may be worthwhile keeping in mind
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Posts
    10
    Rep Power
    0
    Can you access any of the other files on your site?

    Try going directly to one of your other files rather than entering the site through your index.php file?

    That might narrow it down to a problem with the uploaded index.php file. When I browse to your site I get a blank page as well
  14. #8
  15. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Location
    Belfast sumwhere, although it could be Lisburn not too sure
    Posts
    178
    Rep Power
    12
    When i go to your site i get the following error

    Warning: main(include//common.php): failed to open stream: No such file or directory in /usr/local/psa/home/vhosts/noahneiman.com/httpdocs/index.php on line 3

    you have 2 slashes in there m8
  16. #9
  17. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Posts
    41
    Rep Power
    12
    DOH! Thanks for the replies guys. Cheers to all. Got it fixed. I also deleted the "include" files by accident. Double Doh!
  18. #10
  19. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Location
    Belfast sumwhere, although it could be Lisburn not too sure
    Posts
    178
    Rep Power
    12
    Not a bad site m8 liking it

IMN logo majestic logo threadwatch logo seochat tools logo