#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Location
    Netherlands
    Posts
    33
    Rep Power
    12

    Apache error: <OS 10048> Only one usage of each socket address....


    Hey,
    I installed apache a few days ago and tested some simple php scripts on it. However after alot of troubles getting mysql to work apache wouldnt start anymore. I'm getting this error:

    <OS 10048> Only one usage of each socket address <protocol/network address/port> is normally permitted. :make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, Shutting down.
    Besides apache, something else is listening on port 80 as well?

    How can i solve the problem?

    thx in advance.

    P.S. Im running apache on windows.
  2. #2
  3. (retired)
    Devshed Supreme Being (6500+ posts)

    Join Date
    Dec 2003
    Location
    The Laboratory
    Posts
    10,101
    Rep Power
    0
    Yep Something else is sitting on port 80. Maybe a firewall / web-based ADSL admin thing / spyware?.

    I haven't done this in windows for a while, but you should be able to see whats listening on various ports by open up a command prompt and typing:
    Code:
    netstat -a -o
    You can also set apache to listen on another port (8080 is usually chosen here), by changing the port setting in your httpd.conf file.

    --Simon
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2005
    Posts
    1
    Rep Power
    0

    Red face


    I have the answer...
    I fact, it's because we're all using SKYPE, that listens to port 80 that we can't access this port number anymore.

    Go into your SKYPE options, and disable the port 80 is the other port doesn't work...

    Now install the Apache Service :
    apache -k install

    Then start the Apache service using the Apache monitor.

    Verify you have also modified to port 80 in httpd.conf

    Good luck, hope it's gonna help.

    Comments on this post

    • SimonGreenhill agrees : helpful
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2005
    Location
    Kuala Lumpur
    Posts
    1
    Rep Power
    0

    Thumbs down (OS 10048)Only one usage of each socket address (protocol/network address/port)


    man.. I have no SKYPE. even face this problem. what's wrong? I need solution.. Thx for somebody tell this to me.
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2010
    Posts
    1
    Rep Power
    0
    Originally Posted by petit_hom
    I have the answer...
    I fact, it's because we're all using SKYPE, that listens to port 80 that we can't access this port number anymore.

    Go into your SKYPE options, and disable the port 80 is the other port doesn't work...

    Now install the Apache Service :
    apache -k install

    Then start the Apache service using the Apache monitor.

    Verify you have also modified to port 80 in httpd.conf

    Good luck, hope it's gonna help.

    thanx...

IMN logo majestic logo threadwatch logo seochat tools logo