#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2005
    Posts
    418
    Rep Power
    20

    Can't find localhost or ipaddress:port


    Hello,
    I use WAMP server, which is apache, mysql, php, phpmyadmin in one package. I could always go to: http://localhost/ and it would work. I had apache still listening on port 80. However i wanted to make my webserver to be accesible from anywhere, so I tried to change the listen port to 8080. After that I could not acces my server using: http://localhost/ nor using http://myip ort.

    What could be the cause of this?

    Thanks in advance.
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Feb 2004
    Posts
    2,102
    Rep Power
    1767
    are you connecting through a router? if so, you may need to set the port forwarding settings...
  4. #3
  5. Retired
    Devshed Supreme Being (6500+ posts)

    Join Date
    Feb 2002
    Location
    Finland
    Posts
    9,143
    Rep Power
    2493
    If you change the listening port to anything other than 80 (with the exception of SSL [443]) you must specify the port number...

    so http://localhost:8080 should find it locally ...

    and what tj_nt said too.

    Cheers,
    Jamie

    >_ skiFFie ? | Twitter

    __________________

    Let the might of your compassion arise to bring a quick end
    to the flowing stream of the blood and tears .....
    Please hear my anguished words of truth.

    __________________
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2009
    Posts
    18
    Rep Power
    0
    I have the same problem as stefan1, i change the port number in the apache config file to 8080 since i just end up to my modem on port 80. I can access localhost:8080 but http://ip:8080 doesnt work, get the error "broken link" or something like that. Iam not sure if that has to do with:

    Originally Posted by tj_nt
    are you connecting through a router? if so, you may need to set the port forwarding settings...
    If so, how do i set a port forwarding? :S

    Thx for answears.
  8. #5
  9. Retired
    Devshed Supreme Being (6500+ posts)

    Join Date
    Feb 2002
    Location
    Finland
    Posts
    9,143
    Rep Power
    2493

    Cheers,
    Jamie

    >_ skiFFie ? | Twitter

    __________________

    Let the might of your compassion arise to bring a quick end
    to the flowing stream of the blood and tears .....
    Please hear my anguished words of truth.

    __________________
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2009
    Posts
    18
    Rep Power
    0
    wow, thats a long list.

    Hmm ok, iam not even sure what the name of my firewall/router is, if i even have one? lol

    I have the windows firewall activated iam checking it out and it says that apache http server is an exception and will not be blocked.

    I have a DSL connection with vodafone NZ, when loggin in to the modem and check firewall it says its enabled but i dont know the name for the firewall "SmartAX MT882". This is possible whats blocking apache.

    Iam also using a software (sygate personal firewall) however it is not in the list for port forwarding. But i have allowed apache through this firewall.

    Any idea what the name for the SmartAX MT882 modem with vodafone connection could be?


    EDIT---

    Disabled SmartAX MT882 firewall but still couldnt connect to server...

    EDIT---
    Last edited by Jonte; March 17th, 2009 at 06:19 AM. Reason: UPDATE
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2009
    Posts
    18
    Rep Power
    0
    I have now also tried to disable all firewalls and configured my routers security to the following:

    DISABLED Telnet Telnet traffic is blocked from the WAN
    DISABLED FTP FTP traffic is blocked from the WAN
    DISABLED TFTP TFTP traffic is blocked from the WAN
    ENABLED Web Web traffic is blocked from the WAN
    DISABLED SNMP SNMP traffic is blocked from the WAN
    ENABLED Ping Ping traffic is blocked from the WAN

    (not sure of this has anything to do with it)

    I still cant connect to my apacheserver which i downloaded with wamp, i have configured the config file and set my ip and the port 8080 (since router uses port 80)


    What could now possible be the problem?
  14. #8
  15. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2009
    Posts
    18
    Rep Power
    0
    Ok, ive have come to the conclusion that i most likely need to make a port forwarding in my router.

    The router is SmartAX MT882
    Software Release V100R002B020 VODAFONE
    Firmware Release 3.7.9.98


    Anyone that could guide me through how to do this so that i can access my apachewebserver on port 8080?
  16. #9
  17. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2009
    Posts
    18
    Rep Power
    0
    oh, had another look at portforward.com and found my router (well almost) i tried all the three SmartAX MT882 version they had and the one that looks like my version is this one:

    http://portforward.com/english/routers/port_forwarding/Huawei/SmartAX-MT882v2/Apache.htm

    However at the point where iam supposed to: Put a dot into the Redirect radio button.

    I get lost, because i do not have that option in my router, ther is only DMZ and Virtual server to choose from.... No redirect....

    Help me someone pls!

IMN logo majestic logo threadwatch logo seochat tools logo