#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2003
    Posts
    233
    Rep Power
    16

    in modules directory i have only httpd.exp and so files?


    hello all,
    im trying to install apache 2 on fedora core 3 after untar apache.2.0.54 and use configure with option --enable-so or --enable-modules=so ( i tried both )
    make and make install, i expect to have the modules in /apache2/modules/ but the folder contain only 1 file httpd.exp. why? whats wrong?
    some help ?

    thank you
  2. #2
  3. (retired)
    Devshed Supreme Being (6500+ posts)

    Join Date
    Dec 2003
    Location
    The Laboratory
    Posts
    10,054
    Rep Power
    1391
    Because you're just telling apache to enable the use of shared modules. You also need to tell it to MAKE the shared modules.

    You can use these compile flags:
    --enable-mods-shared='headers rewrite dav' (where you list the mods. you want)
    --enable-mods-shared=most ( compiles "most" modules )
    --enable-mods-shared=all ( compiles all modules )

    More info

    --Simon
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2009
    Posts
    1
    Rep Power
    0

    Thanks


    Thanks alot, you saved my time...

IMN logo majestic logo threadwatch logo seochat tools logo