#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2012
    Posts
    3
    Rep Power
    0

    Root directory works, subdirectories do not.


    PHP will not run in subdirectories under document root.

    http://localhost (works)
    http://localhost/index.php (works)
    http://localhost/testdirectory/index.php (DOES NOT WORK)

    I am knew to PHP and Apache 2.2. I am trying to do is set up new projects in subdirectories and test projects which are created under the root that is working.

    Additional information from the httpd conf file.

    <Directory "C:/Apache">

    PHPIniDir "c:\php"
    LoadModule php5_module "c:\php\php5apache2_2.dll"

    Is this a path enviromental issue ? Do I need to add directories onto the <Directory "C:\Apache> ?
  2. #2
  3. Transforming Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    14,113
    Rep Power
    9398
    There is nothing special you need to do.

    What does "not work" mean? Do you see PHP code? Error messages? Have you looked at Apache's logs for any indication of the problem?
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2012
    Posts
    3
    Rep Power
    0
    Originally Posted by requinix
    There is nothing special you need to do.

    What does "not work" mean? Do you see PHP code? Error messages? Have you looked at Apache's logs for any indication of the problem?
    Okay, I'm stupid... you made me think and I think I got confused because Eclipse wasn't serving up the page. That's another issue. Thanks for the response.

IMN logo majestic logo threadwatch logo seochat tools logo