#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Posts
    6
    Rep Power
    0
    I am trying to set up the rewrite module. I want to redirect the quest to another port.

    at the very beginning, I added
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^....URL_NAME....*
    RewriteRule ^/(.*)$ http://localhost:3500/$1 [P] [L]

    It complaints like below
    "Invalid command 'RewriteEngine', perhaps mis-spelled or defined by a module not included in the server configuration"

    Then I added
    LoadModule rewrite_module modules/mod_rewrite.so

    It complaints again like
    "Invalid command 'RewriteEngine', perhaps mis-spelled or defined by a module not included in the server configuration"

    does anyone know the problem?

    Thanks.


  2. #2
  3. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
    >>at the very beginning, I added

    So which file and where exactly? Is it within a <Location> block or <Directory> block or something?

    >>does anyone know the problem?

    What configure option did you give when compiling Apache?
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2000
    Posts
    11
    Rep Power
    0
    Did you compile mod_so into Apache??
    Check if you did by typing: httpd -l
    and make sure that mod_so.c is displayed.

    Otherwise, re-build Apache with mod_so or just compile mod_rewrite statically with
    Apache.

    Hope this helps.

    <BLOCKQUOTE><font size="1" face="Verdana,Arial,Helvetica">quote:</font><HR>Originally posted by freebsd:
    >>at the very beginning, I added

    So which file and where exactly? Is it within a <Location> block or <Directory> block or something?

    >>does anyone know the problem?

    What configure option did you give when compiling Apache?
    [/quote]


IMN logo majestic logo threadwatch logo seochat tools logo