#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2011
    Posts
    4
    Rep Power
    0

    Sub domain redirects


    I have three domains
    domain(dot)net
    domain(dot)com
    m(dot)domain(dot)com

    = I want only two =
    www.domain(dot)com
    m.domain.com

    = should be like this =
    domain(dot)net - to - www.domain(dot)com
    www.domain(dot)net - to - www.domain(dot)com
    domain(dot)com - to - www.domain(dot)com
    m.domain.com - no redirect


    I am close but my m.domain(dot)com keeps redirecting to
    www.m.domain(dot)com/mobile
    thank you
  2. #2
  3. CSS & JS/DOM Adept
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jul 2004
    Location
    USA (verifiably)
    Posts
    20,127
    Rep Power
    4304
    Welcome to DevShed Forums, TacoFiesta.

    Please show us your current redirect rules.

    By the way, you have two domains, not three. One of them has a "m" subdomain in addition to the standard "www" subdomain.
    Spreading knowledge, one newbie at a time.

    Check out my blog. | Learn CSS. | PHP includes | X/HTML Validator | CSS validator | Common CSS Mistakes | Common JS Mistakes

    Remember people spend most of their time on other people's sites (so don't violate web design conventions).
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2011
    Posts
    4
    Rep Power
    0
    RewriteCond %{HTTP_HOST} ^domain\.net$ [OR]
    RewriteCond %{HTTP_HOST} ^domain\.com$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.domain\.net$
    RewriteRule ^/?$ "http\:\/\/www\.domain\.com\/" [R=301,L]
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2011
    Posts
    4
    Rep Power
    0
    2 domains.. ya i noticed that
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2011
    Posts
    4
    Rep Power
    0
    ok so.. everything seems to be working.
    I am having a weird problem with only one page.
    I think it may be in the page...

    so, thanks I guess

IMN logo majestic logo threadwatch logo seochat tools logo