#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2000
    Location
    NY, NY,USA
    Posts
    18
    Rep Power
    0
    I installed RedHat 6.2 yesterday and it put Apache on my machine, which was running beautifully until I started messing with permissions. Now I'm getting the "Forbidden" message.
    My access_log file is giving this:
    207.238.75.66 - - [02/May/2000:14:21:20 -0400] "GET / HTTP/1.1" 403 287

    My error_log file is giving me this:
    [Tue May 2 15:25:21 2000] [error] [client 207.238.75.66] client denied by serve
    r configuration: /home/httpd/html

    Any chance someone could give me a hand with figuring out what permissions I screwed up? I tried to change the groups and owners back to how they started, but I'm guessing that I didn't get it right. Should root own the html directory?

    If I do a ls -al on my httpd directory it looks like this now:
    drwxr-xr-x 5 root root 4096 May 1 10:19 .
    drwxr-xr-x 9 root root 4096 May 2 13:40 ..
    drwxr-xr-x 2 root root 4096 Mar 1 13:37 cgi-bin
    drwxr-xr-x 3 root root 4096 May 2 14:07 html
    drwxr-xr-x 3 root root 4096 May 1 10:21 icons

    Thanks,
    Brett

  2. #2
  3. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
    >>until I started messing with permissions
    What exactly did you do?
    >>Should root own the html directory?If I do a ls -al on my httpd directory...
    Yes.
    Seems to me you messed up your httpd.conf more than the others.
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2000
    Location
    NY, NY,USA
    Posts
    18
    Rep Power
    0
    After a reinstall of linux I went through each of my steps and figured out that things got bad when I tried to change the httpd.conf file.

    RedHat told me that I had to deinstall php and reinstall to make it work with mysql and postgre, so i was in the process of that when I edited the httpd.conf file, so that it wouldn't load the php module. At that point I get forbidden messages when I try to access the server via http.

    I think the permissions are correct on httpd.conf, is there something else that I have to do to make it work..?

    Thanks

  6. #4
  7. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
    You may install postgre and mysql or berkeley db or any database with RPM. Well, there are a few you should NEVER install with RPM, just to name a couple - Apache and PHP. Doing so will almost 99% lead you to a reinstall.
    1) Apache Pre-compiled RPM doesn't enable all the modules/features you might need
    2) You can't change the easily-guessed default location
    3) Upgrading is a pain, it would be better to uninstall and do a fresh install
    4) You may add new modules using Dynamic Shared Object with 'apxs', but most of them don't come with rpm, therefore, you will have to hack the source to make changes for Redhat, this sounds even more troublesome, so WHY NOT compile Apache from source to avoid all these troubles?

    Compiling Apache from source:
    tar -zxvf apache_1.3.12.tar.gz
    cd apache_1.3.12.tar.gz

    Then read the INSTALL file for details. The config.layout file specifies the default layout. When you ready to run ./configure, be sure to specify this at the very least:
    ##########
    ./configure --enable-module=most --enable-shared=max
    ##########

    To install PHP:
    first find out where apxs is. This example is /usr/local/apache/bin/apxs
    tar -zxvf php-4.0RC1.tar.gz
    cd php-4.0RC1
    ./configure --with-apxs=/usr/local/apache/bin/apxs --with-mysql --with-system-regex
    Once this is done, take a look at the libexec directory under your apache installed directory and see if libphp4.so is found there. You may now edit your httpd.conf to enable it.

IMN logo majestic logo threadwatch logo seochat tools logo