1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2000
    Los Angeles, CA
    Rep Power
    okay i've tried every installation procedule possible from various tutorials but nothing seems to work.. did the static installtion, tried various versions of php, apache, etc..

    I have mysql installed correctly and have redhat 6.1 running kernel 2.2.16.

    Here are the steps that I run to install php with apache:

    1.) install mysql
    2.) install apache with config:
    ./configure --prefix=/usr/local/apache --datadir=/home/httpd --logfiledir=/var/log/httpd --enable-module=most --enable-shared=max --disable-rule=WANTHSREGEX
    3.) install php with config:
    ./configure --with-apxs=/usr/local/apache/bin/apxs --with-config-file-path=/usr/local/apache --with-mysql=/usr/local/mysql --with-system-regex

    so far so good.. no error messages

    4.) ran cp php.ini-dist /usr/local/etc/php4.ini (and various other locations to make sure it wasnt this problem)
    5.) editted httpd.conf to have LoadModule php4_module libexec/libphp4.so and AddModule mod_php4.c and
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps
    (weird thing is the loadmodule and addmodule were already uncommented)...

    6.) ./apachectl graceful

    here is where the error message:
    ./apachectl graceful: httpd not running, trying to start
    Syntax error on line 238 of /usr/local/apache/conf/httpd.conf:
    Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: uncompress
    ./apachectl graceful: httpd could not be started

    Any help would be much appreciated. THank you

  2. #2
  3. No Profile Picture
    Devshed Newbie (0 - 499 posts)

    You should then cp your php.ini-dist to /usr/local/apache/php4.ini

    According to "configure" script:
    Sets the path in which to look for php.ini.
    defaults to /usr/local/lib"

    Have you read http://www.devshed.com/Talk/Forums/F...ML/000020.html ?
  4. #3
  5. No Profile Picture
    Gödelian monster
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Jul 1999
    Central Florida, USA
    Rep Power
    I've had the same problem a couple of times, and I found that on occasion with the 'apxs' install, stopping and restarting apache is not enough. When I rebooted the system completely, httpd started fine. (...for what it's worth)

    Also, I notice the error message mentions "undefinded symbol: uncompress". I could be off base on this, but it might be worth checking to see what version of zlib (compression library) is on your system. You should have a file called zlib.h in /usr/include or /usr/local/include. Open it and see if the comments mention whether it is older than version 1.0.9. I am not at all sure whether PHP automatically searches for zlib on install, but you can manually force it. My install used the following:

    unpack zlib-1.1.3, ./configure --shared
    make, make install

    add --with-zlib-dir=shared to your PHP ./configure directives
  6. #4
  7. Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Rep Power

    I am having exactly the same problem as described above with exactly the same error message, which is:

    Cannot load /usr/local/apache/libexec/libphp4.so into server:
    undefined symbol: uncompress

    I have been at loss over this problem and doing everything specified in

    has still not solved my problem. I also did the --with-zlib=pth/to/zlib as suggested, but to no avail (i did not do the uncompress zlib bit or the --shared / --with-zlib=shared though, as it launched the KFM program, which i assume has somthing to do with KDE, and kept giving weird error messages).

    Another thing is that there was no ClearModuleList section in httpd.conf file, so i didn't uncomment/add AddModule mod_php4.c

    Sinilarly, there were no AddTypes in the file so i added "application/x-httpd-php .php4 .php" in the mime.conf file instead - don't know if that was right.

    I am at loss over the problem and have spent over a week now trying to get php4/apache1.1.13/mysql to work together. Is it smthing easy I am doing wrong ???????

    any help greatly appreciated.......


    [This message has been edited by zcrar70 (edited August 13, 2000).]
  8. #5
  9. No Profile Picture
    Devshed Newbie (0 - 499 posts)
    >>i did not do the uncompress zlib bit or the --shared / --with-zlib=shared though

    Just do it. Just follow rycamor's suggestion.
    Also check out -> http://www.phpbuilder.com/mail/php-i...00071/0320.php

    Just install all RPMs that named "zlib" something.

IMN logo majestic logo threadwatch logo seochat tools logo