#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2000
    Posts
    1
    Rep Power
    0
    O.K.. Here is my problem.

    I run a primary server at /home/httpd/html and I use .htaccess to restrict a few directories. That works great!!!

    But.. I also run serveral Virutal Domains on another volume /host/domains. Now if I place a .htaccess file in ANY of the directories on this volume it is not read. It is like it is not ever there..

    Now I have come to the conlusion that the directives in the httpd.conf file tell Apache to look for the .htaccess file in the specified document root directory. Which of course is not the /host volume True?? Not True?

    I have tried placing the AccessFileName .htaccess in the Virtual Host directives area but with no luck. Any thoughts? Prayers? Spiritual Enlightenment?
  2. #2
  3. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
    Start here -> http://www.apache.org/docs/mod/core.html#allowoverride

    Within <VirtualHost 123.456.7.89>, you need to have the following:
    <Directory "/host/domains/www.foobar.com">
    Options All MultiViews
    AllowOverride All
    # or AllowOverride AuthConfig
    Order allow,deny
    Allow from all
    </Directory>

IMN logo majestic logo threadwatch logo seochat tools logo