#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Location
    Moscow
    Posts
    21
    Rep Power
    0

    IIS 5.0 Configuration


    PROBLEM: I am working under Win2k Server with IIS 5.0
    I had AntiViral Toolkit working, but then our sysadmin installed Symantic Antivirus, which conflicted with my system, which resulted in system malfunction. Because antivirus installation was made remotely I first didn't understand what's the problem and wrote it off to the cut of electricity that "luckily" happened the same day. So I updated my system as it is recommended on the Win2k installation CD. Then I realised that the problem was in my AVP and deinstalled it, so everything works now, even web-services (the web pages are loading), except the following: when I open IIS Manager and try to see the list of web/ftp pages I get the following error messages:
    --------------------------------------------------------------------------
    Unable to enumerate FTP sites because the following error occurred: Object already exists.
    --------------------------------------------------------------------------
    and
    --------------------------------------------------------------------------
    Unable to enumerate Web sites because the following error occurred: Object already exists.
    --------------------------------------------------------------------------

    I tried to solve it by reinstalling the IIS components, but during the installation I got the following message:
    --------------------------------------------------------------------------
    Error writing encrypted data to the Web server's configuration database (Metabase).
    0x8009000f=Object already exists.
    Press 'Retry' to retry or 'Write UnEncrypted' to write the data unencrypted. YOU CAN CHANGE THIS DATA BACK TO ENCRYPTED AFTER SETUP HAS COMPLETED.
    --------------------------------------------------------------------------
    I chose 'UnEncrypted'. But after that the same story.
    I would be greatful if someone helps me with this problem. Also I am interested in that last sentence of the error message: How can I change this data back to encrypted?
  2. #2
  3. No Profile Picture
    Average Intelligence
    Devshed Novice (500 - 999 posts)

    Join Date
    Apr 2003
    Location
    Ohio/Chicago
    Posts
    678
    Rep Power
    16
    This particular problem can occur during an installation or reinstallation of IIS 5.0. Reinstallations may be necessary if a problem is caused by a problem that occurred during the initial installation of Windows 2000, where IIS 5.0 is installed by default or IIS 4.0 is upgraded to IIS 5.0. You can fix the problem as follows:

    Remove IIS
    Use Windows Explorer to navigate to the:
    %Windir%\Profiles\All Users\Application Data\Microsoft\Crypto\Rsa\MachineKeys directory.

    Rename the Machinekeys folder to Machinekeys1
    Reinstall IIS.
    If all goes well, and it should, delete the Machinekeys1 folder
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Location
    Moscow
    Posts
    21
    Rep Power
    0
    Thank you very much, that worked perfectly, except it crashed my VSS but this one has good fixing tools.
  6. #4
  7. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Posts
    1
    Rep Power
    0
    I have the same problem as Uga, I am running Norton AV 2003 and I get the same error on installation of IIS 5.0 onto my XP machine (Pro)... also when I get it installed there is nothing in my IIS tree, could you help me too
  8. #5
  9. No Profile Picture
    Average Intelligence
    Devshed Novice (500 - 999 posts)

    Join Date
    Apr 2003
    Location
    Ohio/Chicago
    Posts
    678
    Rep Power
    16
    I really only work with windows 2000 and 2003 servers, you'll have to google around for it, sorry.

IMN logo majestic logo threadwatch logo seochat tools logo