Hi There,

I am having difficulties with navigation, i have been on it for two days but cannot fix it.

It must be some small error where I am going wrong.

I have a sub side-navigation on each page, when these pages opened from main navigation. Main navigation work fine, also most of sub pages navigation works fine but for some of them they wont highlight when they clicked.

First part below works fine but second one when I click Online Platform the sub link opens Mobile walkthrough, and when I click Mobile walkthrough, page opens on the side but navigation closes, Mobile walkthrough doesn't stay opened like on other pages. I want navigation to stay opened. I have compared few of new pages with old ones and everything is the same, cannot find any difference but it doesnt work.

<asp:PlaceHolder ID="navComp1" Visible="false" runat="server">
<ul>
<li class="<%=GetNavClass("hardware,disk") %>"><a href="hardware.aspx">
Shop</a>
<ul>
<li class="<%=GetNavClass("disk") %>"><a href="disk.aspx">
Disks</a></li>
</ul>
</li>
<li class="<%=GetNavClass("software,program") %>"><a href="software.aspx">Software</a>
<ul>
<li class="<%=GetNavClass("program") %>"><a href="program.aspx">Program
Examples</a></li>
</ul>
</li>

</ul>
</asp:PlaceHolder>

<asp:PlaceHolder ID="navComp2" Visible="false" runat="server">
<ul>

<li class="<%=GetNavClass("platform,platformwalk") %>"><a href="platform.aspx">Online
Platform</a>
<ul>
<li class="<%=GetNavClass("platformwalk") %>"><a href="platformwalk.aspx">
Platform walk</a></li>
</ul>
</li>
<li class="<%=GetNavClass("mobileplatform, mobilewalkthrough") %>"><a href="mobileplatform.aspx">Mobile Platform</a>
<ul>
<li class="<%=GetNavClass("mobilewalkthrough") %>"><a href="mobilewalkthrough.aspx">
Mobile walkthrough</a></li>
</ul>
</li>
</ul>
</asp:PlaceHolder>