#1
  1. No Profile Picture
    Cheeky Deeky
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2004
    Location
    Los Angeles, CA
    Posts
    5
    Rep Power
    0

    Angry Request.Form method in Classic ASP generates a generic error


    I am unable to grab any form data using the Request.Form("item") method in Classic ASP. It generates a very generic error with no description. However, it works just fine in ASP.NET. (The problem also occurs with the Request("item") syntax.)

    I don't have any problems with any other Request methods in Classic ASP.

    This is a copy of sample code I wrote, which throws the error:
    (Form Page: form.asp)
    Code:
    <form name="test" action="test.asp" method="post">
         <input type="text" name="stuff" />
         <input type="submit" name="submit" value="Try It" />
    </form>
    (Output Page: test.asp)
    Code:
    <%
    mytest = Request.Form("stuff")
    Response.Write(mytest)
    %>
    This is what I receive:
    error '80004005'
    <my path>/test.asp, line 2

    Line 2 is the mytest = Request.Form("stuff") line.

    Error Tracing from IIS:
    ERROR:
    ASP_LOG_ERROR
    LineNumber 3
    ErrorCode 80004005
    Description

    Warning:
    MODULE_SET_RESPONSE_ERROR_STATUS
    ModuleName IsapiModule
    Notification 128
    HttpStatus 500
    HttpReason Internal Server Error
    HttpSubStatus 0
    ErrorCode 0
    ConfigExceptionInfo
    Notification EXECUTE_REQUEST_HANDLER
    ErrorCode The operation completed successfully. (0x0)


    This is the ASP entry in the applicationHost.config file:
    <add name="ASPClassic" path="*.asp" verb="*" modules="IsapiModule" scriptProcessor="%windir%\system32\inetsrv\asp.dll" resourceType="Unspecified" requireAccess="Script" />

    The server is IIS7.

    Any help would be greatly appreciated.
  2. #2
  3. No Profile Picture
    Cheeky Deeky
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2004
    Location
    Los Angeles, CA
    Posts
    5
    Rep Power
    0
    Fixed the problem on my own!

    In the event someone else should experience this, setting the DefaultAppPool to Classic did the trick!

IMN logo majestic logo threadwatch logo seochat tools logo