#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2006
    Posts
    3
    Rep Power
    0

    Question Xml object and weird "?" characters


    I'm trying to get a .txt file from another domain using xml object; this file includes special characters like , , , , , and so on.

    The code I'm using is:


    Set xml = Server.CreateObject("MSXML2.ServerXMLHTTP")
    xml.Open "GET", "http://domain/file.txt", False
    xml.Send
    If err.number = 0 then filebody = xml.responseText
    set xml = nothing


    The problem is that all those chars are converted to "?" symbols!

    How can I get rid of this thing and get the original characters back?

    Thanks a lot 4 your time!

    Toby C
  2. #2
  3. Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Jun 2004
    Location
    Hampshire, UK
    Posts
    990
    Rep Power
    315
    do you have access to the actual xml file? check that the encoding on the file is UTF-16
    Scott Perham, BSc (hons), CCNA, MCPD
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2006
    Posts
    3
    Rep Power
    0

    Question not xml but txt file


    Thanks scoper for replying!

    The file is a simple text file, a "name.TXT", plain text.


    Toby C
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2013
    Posts
    1
    Rep Power
    0
    Hi,

    Do you have the soluction?

    I have similar problem, but I cannt with the problem.

    Can you help me?

    Thanks

IMN logo majestic logo threadwatch logo seochat tools logo