#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Posts
    3
    Rep Power
    0

    Data source name not found and no default driver specified


    Hi

    We had a web site that works in windows NT very good with a DB in Access. Our clients migrate to Win 2000 and now the connection to the DB doesn't work,...the error is this:

    Error: Access is Denied.
    Microsoft OLE DB Provider for ODBC Drivers error '80004005'

    [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

    /directory/progs/utils.inc, line 17

    The code is this

    Sub ConectarBd(NomDSN)
    Connect_String = "DSN=lmsfamilia;"
    db.Open Connect_String
    End Sub

    What could it be?

    Thanks
    JP
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2003
    Location
    Canada, Quebec, Montreal
    Posts
    410
    Rep Power
    12
    Make sure your client has a DSN named lmsfamilia on his machine.

    To check that, simply go to :

    Start-->Programs-->Administrative Tools-->Data Source(ODBC)
    then click the System DSN tab and *look* if its there...

    If not, then create it!

    Hope this helps!
    Sincerely

    Vlince
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Posts
    3
    Rep Power
    0

    I've already done that DSN


    Hi!

    I'm sure the DSN is created in Data Source(ODBC)


    I'm really confused...two days with this error....the DSN is created...the users IWAM_ and IUSR_ have the rigth permision to the folder....so ...mh?


    Help please


    Thanks

    JP
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2003
    Location
    Canada, Quebec, Montreal
    Posts
    410
    Rep Power
    12
    OK then there is NOTHING *I* can do from here...in Montreal!

    You'll need to DEBUG

    Start from the beginning,

    Create a simple .asp page that does this:
    --------------------------------------------------
    <html>
    <body>

    <%Response.Write Now()%>

    </body>
    </html>
    --------------------------------------------------


    then move up one leve...

    Create a *second* .asp page that *tries* to connect to your database.
    Use an OLEDB connection instead of a DSN to connect to your Access database
    Look here: http://www.able-consulting.com/ADO_Conn.htm

    Now you do NOT have much choice to go step by step in order to identify the problem

    I wish I could help you more...honestly!

    If the OLEDB approach doesn't work then try creating a *NEW* DSN following the steps in the wizard.

    Hope this helps!
    Sincerely

    Vlince
  8. #5
  9. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,443
    Rep Power
    4539
    Double-check your DSN. If you have a typo in the path to the .mdb file you can get this error.

    If the .mdb file is in some location outside of your web, make sure the IIS user account has permissions to the .mdb file.

    You can download and install newer MDAC packages from MS at www.microsoft.com/data You need to download Jet (Access) drivers separately.

    It is remotely possible there is a registry permissions problem where IIS can't get to the DSN registry entries.
  10. #6
  11. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Posts
    2
    Rep Power
    0
    Try removing "DSN=" from the connection string... we've often found that that is the cause of problems even though it shouldn't be....eg

    Code:
    Connect_String = "lmsfamilia"
    (Plus remove the SemiColon)

    Also.. make absolutely sure it's a system DSN
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2010
    Posts
    1
    Rep Power
    0
    Also.. make absolutely sure it's a system DSN
    Thanks, I had mistakenly created a "User DSN".

    Definately make sure it's a "System DSN" when troublshooting this issue.
  14. #8
  15. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2011
    Posts
    1
    Rep Power
    0

    Exclamation Another solution


    I re-factored my file to put spaces between all the '=' symbols for readability. Unfortunately I did a global search and replace. That inadvertently added spaces between the DSN and the name. i.e "DSN = sourceName". Well some of you probably know that there can't be spaces between DSN and the name. So make sure yours looks like this: "DSN=sourceName" Hope this helps someone!
  16. #9
  17. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,443
    Rep Power
    4539
    Originally Posted by vcoleman
    I re-factored my file to put spaces between all the '=' symbols for readability. Unfortunately I did a global search and replace. That inadvertently added spaces between the DSN and the name. i.e "DSN = sourceName". Well some of you probably know that there can't be spaces between DSN and the name. So make sure yours looks like this: "DSN=sourceName" Hope this helps someone!
    Thanks for the reply. Did you happen to notice this topic is 8 years old? I doubt the original poster is reading.
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester

IMN logo majestic logo threadwatch logo seochat tools logo