Thread: freeBSD

    #1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2000
    Posts
    15
    Rep Power
    0
    ok, I'm new, but I had freeBSD installed on my PC and boots fine, but even I am connected to network, it doesn't connect to any site I want to view with Netscape.

    I want to know how I can configure the network configuration on freeBSD.

    TIA.

    ------------------
    http://millennium.massassi.net/
  2. #2
  3. SwollenMember
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Location
    the master control
    Posts
    264
    Rep Power
    14
    it might just be a simple problem with DNS, if you can ping an ip, but not a domain name, then you have a dns problem. you can fix this in netscape. if this is not the problem, then i think you can use netconf.
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2000
    Posts
    15
    Rep Power
    0
    ok, I have a note-book pc connected through a LAN from a desktop, the desktop has a dial-up modem. Is it possible for the note-book PC to be connected to the internet via the LAN?

    I have this working for Win98, but is it still possible for freeBSD?

    ------------------
    http://millennium.massassi.net/
  6. #4
  7. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
    >>I have this working for Win98, but is it still possible for freeBSD?

    Yes.

    Show me your /etc/rc.conf
  8. #5
  9. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2000
    Posts
    15
    Rep Power
    0
    Since I don't know how to connect to the net on freeBSD, I can't just copy&paste here, so I'll try to read and type it. I'll leave out the comments in the actual file.

    pccardd_flags=" -i 1 -i 2 -i 3 -i 4 -i 5 -i 6 -i 7 -i 8 -i 9 -i 10"
    pccard_mem="DEFAULT"
    moused_port="/dev/psm0"
    moused_enable="YES"

    keymap="jp.106"
    hostname="laptop.sfc.keio.ac.jp"

    hostname="laptop.sfc.keio.ac.jp"
    network_interfaces="auto"
    pccard_ether="wi0 ed0 ep0"
    ifconfig_fxp0="DHCP"
    ifconfig_ed0="DHCP"
    ifconfig_ep="DHCP"
    ifconfig_wi0="DHCP"
    linux_enabled="YES"
    keymap="jp.106"
    sendmail_enable="NO"
    moused_port="/dev/psm0"
    moused_type="auto"
    moused_flags="-3 -z 4"
    moused_enabled="YES"
    pccard_enabled="YES"
    pccardd_flags=""
    pccard_mem="DEFAULT"
    apm_enable="YES"
    apmd_enable="YES"

    That's all without comments.

    ------------------
    http://millennium.massassi.net/

    [This message has been edited by Hideki (edited October 27, 2000).]
  10. #6
  11. No Profile Picture
    freebsd
    Guest
    Devshed Newbie (0 - 499 posts)
    Are you sure you have a DHCP server running at your Win98 Desktop? If so, your rc.conf looks fine. Otherwise, you have a few options:
    (1) Get Sygate at http://www.sygate.com/free/sgdownload.htm and disable Internet Sharing for your Win98 Desktop (only if it's running) and let Sygate take care everything.

    (2) Do not use DHCP:
    ifconfig_fxp0="DHCP"
    ifconfig_ed0="DHCP"
    ifconfig_ep="DHCP"
    ifconfig_wi0="DHCP"
    You need to figure out which network interface is actually connecting to your Desktop.

    Example:

    Desktop PC has a NIC assigned to a local static IP -> 192.168.0.1 and netmask -> 255.255.255.0

    Laptop's NIC, set your defaultrouter to 192.168.0.1 and assign a local IP (i.e. 192.168.0.2 manually).
    You can do this via /stand/sysinstall but with GUI tool, you LEARN nothing. So to do it by hand, start editing rc.conf directly.
    Let say ed0 is the interface connect to your Desktop, you need to change your "ifconfig_ed0="DHCP"" line to:

    ifconfig_ed0="inet 192.168.0.2 netmask 255.255.255.0"
    Then add this line right below it:
    defaultrouter="192.168.0.1"

    If you choose the Sygate method, be sure to enter the proper nameserver IPs in the "Advanced" configuration.
    For the other method, edit /etc/resolv.conf like so:

    domain sfc.keio.ac.jp
    nameserver 123.45.67.89
    nameserver 123.45.67.90

    Note, you may try the "whois" command to find that out.

    Be sure to update your /etc/hosts file as well.


IMN logo majestic logo threadwatch logo seochat tools logo