#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Posts
    2
    Rep Power
    0
    I have contacted the powers that be at all 3 of these sites, looking for help to no avail. Hence why I'm posting here.

    Apache - 'cannot connect to localhost'
    PHP4 - an INF file is needed (not included in download from php.net)
    MySQL - mySQLd-shareware.exe was not included in the download either.

    Anyone whom could help me get this running would be greatly appriciated.

    Regards,
    Kyle F.
    Kyle@footbag.org
  2. #2
  3. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Posts
    2
    Rep Power
    0
    >>Apache - 'cannot connect to localhost'
    first of all, check the httpd.conf
    I think you have to change something in there. Check the documentation, I'm not sure exactly. Also, to make php work with apache you need to add following lines:

    ScriptAlias /php4/ "C:/php4/"
    AddType application/x-httpd-php3 .php3
    Action application/x-httpd-php3 "/php4/php.exe"

    >>PHP4 - an INF file is needed (not included in download from php.net)

    umm. yes, it is, actually. they did forget to include it. However, you can just fire up regedit and add this value:

    ".php"="C:Program FilesPHPphp4isapi.dll"

    (editing the location to that of your php install of course)
    in this key:

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesw3svcparametersScript Map]

    >>MySQL - mySQLd-shareware.exe was not included in the download either.

    what file did you download? this one (5.04 Mb) has everything included.

    mysql-shareware-3.22.33-win.zip


    that should get you started. more or less, anyway


    peace on earth.

    a.

    [This message has been edited by lucky23 (edited May 29, 2000).]
  4. #3
  5. No Profile Picture
    Robert_J_Sherman
    Guest
    Devshed Newbie (0 - 499 posts)
    <BLOCKQUOTE><font size="1" face="Verdana,Arial,Helvetica">quote:</font><HR>Originally posted by lucky23:

    >>PHP4 - an INF file is needed (not included in download from php.net)

    However, you can just fire up regedit and add this value:

    ".php"="C:Program FilesPHPphp4isapi.dll"

    (editing the location to that of your php install of course)
    in this key:

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesw3svcparametersScript Map]
    [/quote]

    And what if your system doesn't contain the detailed registry key???

    I'm running PHP4, MySQL, and Apache and things seem to be fine, unless I name the PHP.ini to php.ini, in which case php has
    big problems. Of course, if I leave it named as php4.ini then when I run phpinfo() most of my entered values appear to be completely ignored.


    ------------------
    SnR Graphics,
    Low Cost Hosting and Web Development.
  6. #4
  7. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Posts
    2
    Rep Power
    0
    The problem with the "local host" was (at least on my win98 machine) the following:
    goto settingscontrol panelnetworkidentification and check what is in the computer name field (you can change this if you like, and then restart.

    Then in your httpd.conf file, make sure you have the following:

    ServerName computer name

    where computer name = whatever u have called it. Worked for me anyway.

IMN logo majestic logo threadwatch logo seochat tools logo