#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2000
    Location
    Morrow, Ga
    Posts
    3
    Rep Power
    0
    Would really appreciate some guidance on getting PHP running in my browser. I am able to see script output when I type PHP scriptname.php3 from the command prompt but not in my browser( IE 5.0). I'm using apache 1.3.12, windows98 and PHP3. Apache is running fine. here is a shot of my Httpd.conf file and the only line I believe is relevant in PHP.ini. I followed the instructions verbatim.

    ScriptAlias /php3/ "c:/Php3/"

    AddType application/x-httpd-php3 .php3

    AddType application/x-httpd-Php3 .php3 .phtml .php

    Action application/x-httpd-php3 "/Php3/php.exe"

    php.ini is in Windows directory
    extension_dir = "C:Php3;


    <Directory "c:/Apache/htdocs">
    This says to serve my scripts from htdocs, I've tried that and the ScriptAlias directory to no avail. My root directory is C:apache.

    appreciate some guidance.

  2. #2
  3. Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Feb 2000
    Location
    Perth West Australia
    Posts
    757
    Rep Power
    15
    This is a bare-bones config, make a backup of your old .conf and try this one, if it works you can start adding the other stuff.

    Port 80
    ServerName localhost
    #assuming c:/php3/ is where php3 is!
    ScriptAlias /php3/ "C:/php3/"
    AddType application/x-httpd- .php3 .htm
    Action application/x-httpd-php3 "/php3/php.exe"
    ServerRoot "C:/apache"
    DocumentRoot "C:/apache/htdocs/"
    MaxClients 150
    MaxRequestsPerChild 0
    <Directory />
    AllowOverride none
    Options FollowSymLinks
    </Directory>

    Run Apache and type in http://localhost & see how it goes. Please back-up your old config.



    ------------------
    Simon Wheeler
    FirePages -DHTML/PHP/MySQL

IMN logo majestic logo threadwatch logo seochat tools logo