#1
  1. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2011
    Posts
    158
    Rep Power
    97

    FreeBSD 9.0 - PHP 5.3.8 - PostgreSQL 9.1.2


    Hello everyone,

    I'm having issues with FreeBSD 9.0. I have PHP 5.3.8 installed as well as PostgreSQL 9.1.2.

    The "port" that's available for the version of PHP I have installed is only for PostgreSQL 8.4.10, which is not suitable.

    I am wondering how can I go about compiling a custom PHP 5.3.8 module to interface with the PostgreSQL 9.1.2 I have installed.
  2. #2
  3. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2011
    Posts
    158
    Rep Power
    97
    I went around the net looking and I didn't find much with what I was searching for but eventually came across using:

    sudo make config
    make
    make install

    This also will allow me to remove the package later with pkg_delete, I'm just waiting on news as to whether or not it will work with postgresql 9.1.2. The pre-compiled ports all required postgresql-client 8.4.10. We shall see.
  4. #3
  5. Banned ;)
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2001
    Location
    Woodland Hills, Los Angeles County, California, USA
    Posts
    9,595
    Rep Power
    4207
    You could also try installing PHP from source instead of from ports and that way, you can get a later version of PHP as well, with all the bugfixes. That's how I used to do it when I was administering FreeBSD boxes.
    Up the Irons
    What Would Jimi Do? Smash amps. Burn guitar. Take the groupies home.
    "Death Before Dishonour, my Friends!!" - Bruce D ickinson, Iron Maiden Aug 20, 2005 @ OzzFest
    Down with Sharon Osbourne

    "I wouldn't hire a butcher to fix my car. I also wouldn't hire a marketing firm to build my website." - Nilpo

IMN logo majestic logo threadwatch logo seochat tools logo