Page 2 of 2 First 12
  • Jump to page:
    #16
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2001
    Posts
    4
    Rep Power
    0
    >> version of config(8) does not match kernel

    What did you do (in details) prior to that?

    >> it worked b4

    There is no such thing as it worked b4 it's failing now.

    Show us what's in your /var/db/pkg/ right now.
  2. #17
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Posts
    174
    Rep Power
    18
    6tunnel-0.07 gtop-1.0.12
    Mesa-3.4.1 guile-1.4
    ORBit-0.5.7 gupsc-0.3.1
    VisualOS-1.0.3 gvid-0.2
    afterstep-1.0 healthd-0.6.5
    autoconf-2.13 iconv-2.0_1
    automake-1.4 imlib-1.9.9
    battstat-applet-2.0.4 ipsc-0.4.2
    bitnotes-0.9 jbigkit-1.2
    blackbox-0.61.1 jpeg-6b
    bonobo-0.37 kde-2.1.1
    bonobo-conf-0.1 kdebase-2.1.1
    bugbuddy-1.2 kdegames-2.1.1
    bulb-1.0.6 kdegraphics-2.1.1
    bzip2-1.0.1 kdelibs-2.1.1
    cftp-0.10 kdemultimedia-2.1.1
    cucipop-1.31_2 kdenetwork-2.1.1
    cvsup-16.1e kdesupport-2.1
    dedit-0.6.2.1 kdeutils-2.1.1
    diacanvas-0.40.1 koffice-2.0.1_2
    e16utils-0.16 lcms-1.07
    electriceyes-0.3.12 libaudiofile-0.2.1_1
    emacs-20.7 libepplet-0.5
    enlightenment-0.16.5_5 libghttp-1.0.9
    eog-0.6 libglade-0.16
    esound-0.2.22 libgtop-1.0.11
    etherape-0.5.7 libiconv-1.6.1
    fetchmail-5.7.6 libmng-1.0.0_1
    finder-0.80.4 libmorph-0.1.2
    fnlib-0.5 libole2-0.2.0
    fpx-1.2.0 libslang-1.4.4_1
    freetype-1.3.1_1 libtool-1.3.4_2
    freetype2-2.0.5 libungif-4.1.0b1
    gaddr-1.1.4 libunicode-0.4_2
    gal-0.5 libunp-1.0
    gbackground-1.0.0.b2 libwww-5.3.1
    gconf-0.12_1 libxml-1.8.11
    gdbm-1.8.0 linux_base-6.1
    gdk-pixbuf-0.9.0_1 lukemftpd-1.0
    gdm-2.0b4_2 m4-1.4
    gettext-0.10.35 mlvwm-0.9.1
    ggv-0.95 mmc-0.5
    ghex-1.1.4 morpheus-0.3
    ghostscript-6.50_6 mosaic-2.7b5
    glacier-0.0.2 mpg123-0.59r_3
    glade-0.5.11 mtr-gtk-0.42
    glib-1.2.10 netris-0.5
    glibwww-0.2 oaf-0.6.2
    glife-0.2.1 open-motif-2.1.30_1
    gmake-3.79.1 p5-Socket6-0.08
    gmanedit-0.3.1 pchar-1.3.2
    gnat-3.13p pea****-0.2
    gnofin-0.8.4 pidentd-2.8.5
    gnomba-0.5.1 png-1.0.10
    gnome-1.2 png-1.2.1
    gnome-vnc-0.1 popt-1.5.1
    gnomeapplets-1.2.4 powershell-0.8
    gnomeaudio-1.0.0 py-gnome-1.0.53
    gnomebreakout-0.5.1 py-gtk-0.6.6
    gnomecontrolcenter-1.2.2_2 pyfind-0.8.0
    gnomecore-1.2.4 pygmy-0.5.4
    gnomecrash-0.0.5 python-2.0
    gnomefind-1.0.1 pythoong-0.99
    gnomegames-1.2.0 qpopper-4.0_1
    gnomekiss-0.7 qt-2.3.0
    gnomelibs-1.2.11 rcalc-0.2.2
    gnomemc-4.5.51 rsync-2.4.6_2
    gnomemedia-1.2.0 slrn-0.9.7.0
    gnomepim-1.2.0 solidpop3d-0.15_1
    gnomepm-0.9.3 sox-12.17.1_1
    gnomeprint-0.25 spat-1.0
    gnomeres_applet-0.6.0 stockticker_applet-0.2.2
    gnometelnet-2.4 svgalib-1.4.2_1
    gnomeusersguide-1.2 t1lib-1.1.0
    gnomeutils-1.2.1 tcptrace-5.2.1
    gnomevfs-0.5 teTeX-1.0.7
    gnosamba-0.3.3 tiff-3.5.5
    gnubile-0.20 uulib-0.5.13
    gnumeric-0.61 webfs-1.6
    gonvert-0.0.5 wmg-0.15.0
    grdb-0.2.4 xanim-2.80.2
    gswitchit_applet-0.70 xchat-1.6.4
    gtetrinet-0.4.1 xml-i18n-tools-0.8
    gtk-1.2.10 xpm-3.4k
    gtk-engines-0.12 xwave-2.2
    gtkdiff-1.0.2 yamt-0.5
    gtkglarea-1.2.2 yank-0.2.0
    gtktetcolor-0.5.0
  4. #18
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Posts
    174
    Rep Power
    18
    all that was installed from cd,
    awhile ago. I did run kernel compile b4
    trying custom but just ended back at GENERIC which also does not work now

    So I
    rm -rf /usr/ports
    CDrom
    install ports
    cvsup stable-supfile

    so my src is 4.4 while the rest is 4.3
  6. #19
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2001
    Posts
    4
    Rep Power
    0
    >> all that was installed from cd awhile ago

    Oh no... You should never install software from /stand/sysinstall (or initial install). Doing so you will likely end up reinstalling FreeBSD from scratch very soon.

    So let's forget about your installed software and upgrade to 4.5-PRERELEASE for now.

    >> version of config(8) does not match kernel

    This tells me 4.5-PRERELEASE uses a different /usr/sbin/config, so you need to build+update your config. To be safe, build the new config (/usr/src/usr.sbin/config to /usr/obj) and install it to /destdir/usr/sbin/config.

    Here's how to do it:
    1) mkdir /destdir
    2) mkdir /usr/obj (if it already exists, rm -rf /usr/obj and redo mkdir /usr/obj)
    3) cd /usr/src/usr.sbin/config
    4) make obj
    5) setenv DESTDIR /destdir (NetBSD uses this alot, very reliable and safe. FreeBSD needs to learn that someday)
    6) make cleandir
    7) make depend && make
    8) make install
    9) cd to /destdir/usr/sbin and see if config is there (you will be using this config to config your MYKERNEL)
    10) cd /usr/src/sys/i386/conf
    11) unsetenv DESTDIR
    12) /destdir/usr/sbin/config MYKERNEL
    13) cd ../../MYKERNEL
    14) make depend
    15) make
    16) make install
    17) reboot and test your new kernel, if it fails to boot, reboot to single user mode and boot your kernel.old file.
    18) cd /usr/src
    18) find . -type l -name obj | xargs rm
    19) make cleandir
    20) make obj

    Then do buildworld. After buildword but before reboot, recompile your kernel again with the new config at /usr/sbin/config (not the one in /destdir this tme).
    You know what, you were supposed to follow the Procedure 2. Building a kernel the ``new'' way at http://www.freebsd.org/doc/en_US.ISO...-building.html but it's too late right now.
  8. #20
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Posts
    174
    Rep Power
    18
    127# mkdir /destdir

    127# rm -rf /usr/obj

    127# mkdir /usr/obj

    127# cd /usr/obj[K[K[Ksrc/usr.sbin/config

    127# make obj

    /usr/obj/usr/src/usr.sbin/config created for /usr/src/usr.sbin/config
    127# setenv DESTDIR /destdir

    127# make cleandir

    127# make depend && make

    yacc -d config.y
    cp y.tab.c config.c
    yacc -d config.y
    cp y.tab.c config.c
    rm -f .depend
    mkdep -f .depend -a -I. -I/usr/src/usr.sbin/config -I/destdir/usr/include config.c main.c lang.c mkioconf.c mkmakefile.c mkheaders.c mkoptions.c
    cd /usr/src/usr.sbin/config; make _EXTRADEPEND
    echo config: /destdir/usr/lib/libc.a /destdir/usr/lib/libl.a >> .depend
    Warning: Object directory not changed from original /usr/src/usr.sbin/config
    yacc -d config.y
    cp y.tab.c config.c
    cc -O -pipe -I. -I/usr/src/usr.sbin/config -Wall -Wunused -Wmissing-prototypes -Wredundant-decls -I/destdir/usr/include -c config.c
    yacc -d config.y
    cp y.tab.c config.c
    cc -O -pipe -I. -I/usr/src/usr.sbin/config -Wall -Wunused -Wmissing-prototypes -Wredundant-decls -I/destdir/usr/include -c main.c
    cc -O -pipe -I. -I/usr/src/usr.sbin/config -Wall -Wunused -Wmissing-prototypes -Wredundant-decls -I/destdir/usr/include -c lang.c
    lang.l:1027: warning: `yy_flex_realloc' defined but not used
    cc -O -pipe -I. -I/usr/src/usr.sbin/config -Wall -Wunused -Wmissing-prototypes -Wredundant-decls -I/destdir/usr/include -c mkioconf.c
    cc -O -pipe -I. -I/usr/src/usr.sbin/config -Wall -Wunused -Wmissing-prototypes -Wredundant-decls -I/destdir/usr/include -c mkmakefile.c
    cc -O -pipe -I. -I/usr/src/usr.sbin/config -Wall -Wunused -Wmissing-prototypes -Wredundant-decls -I/destdir/usr/include -c mkheaders.c
    cc -O -pipe -I. -I/usr/src/usr.sbin/config -Wall -Wunused -Wmissing-prototypes -Wredundant-decls -I/destdir/usr/include -c mkoptions.c
    cc -O -pipe -I. -I/usr/src/usr.sbin/config -Wall -Wunused -Wmissing-prototypes -Wredundant-decls -I/destdir/usr/include -o config config.o main.o lang.o mkioconf.o mkmakefile.o mkheaders.o mkoptions.o -ll
    make: don't know how to make config.1. Stop
    127#

    well I'm ready to reinstall
    Thing is I don't know how to dialup
    from console so i need KDE at least
  10. #21
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2001
    Posts
    4
    Rep Power
    0
    Seems like you also need to build /usr/src/share/mk and /usr/src/usr.bin/make as well.

    >> well I'm ready to reinstall

    Maybe not. As I said, during code freeze period, you shouldn't cvsup your src in the first place. So why don't you just rm -rf /usr/src, /usr/obj, /destdir and /usr/sup. Then install your full source back to /usr/src. Just play around with 4.4-RELEASE for a while would make your life easier. Like I said, when 4.5-STABLE is out, just follow Procedure 2. Building a kernel the ``new'' way.
  12. #22
  13. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Posts
    174
    Rep Power
    18
    ok

    thanks alot

    so right now the src is 4.5 prelease

    which is "under construction"

    not for newbies possibly much debug

    and stable is obviously the debugged tree

    how can i check my src version
    Last edited by Bob Loblaw; January 3rd, 2002 at 07:01 PM.
  14. #23
  15. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2001
    Posts
    4
    Rep Power
    0
    >> how can i check my src version

    /usr/src/sys/conf/newvers.sh

    Check REVISION and BRANCH. So your src version is REVISION-BRANCH.

    You should remove your /usr/src and put your 4.4-RELEASE src back.
Page 2 of 2 First 12
  • Jump to page:

IMN logo majestic logo threadwatch logo seochat tools logo