#1
  1. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Sep 2000
    Posts
    763
    Rep Power
    0

    Installing ClamAV-0.87.1 on OpenBSD


    Hey,

    I have been trying to get clamav-0.87.1 on an openbsd 3.7 box using the package system.

    I use the pkg_add command like so.
    Code:
    pkg_add http://ftp.openbsd.org/pub/OpenBSD/3.7/packages/i386/clamav-0.87.1.tgz
    This however, returns this error.
    Code:
    Can't install ftp://ftp.openbsd.org/pub/OpenBSD/3.7/packages/i386/clamav-0.87.1.tgz: lib not found curl.3.1
    Even by looking in the dependency tree:
            arc-5.21e, unzip-5.51, unarj-2.43, gmp-4.1.4, zoo-2.10.1, curl-7.11.2p0, unrar-3.43, bzip2-1.0.2, lha-1.14i.p0
    Maybe it's in a dependent package, but not tagged with @lib ?
    (check with pkg_info -K -L)
    If you are still running 3.6 packages, update them.
    It seems to have a problem with curl.3.1 lib or something like that. I have googled for curl.3.1 and found nothing usefull. I also googed for help on installing clamav but no one seems to be having this problem.

    Any ideas.

    Thanks.
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2004
    Posts
    296
    Rep Power
    0
    Well... I had some problems in the past with other pkg, and the problem was that I
    didn't install X at all. So from now, every time when I install openbsd, I always
    install the X stuff even if I don't run the X server.
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Sep 2000
    Posts
    763
    Rep Power
    0
    Hmm, I dont have x11 installed and have always been able to find packages that dont require it.

    Edit.

    Turns out I just needed to install curl-7.15....... Ugggg *smaks head against brick wall again*
    Last edited by Eclipce; November 21st, 2005 at 02:34 PM.

IMN logo majestic logo threadwatch logo seochat tools logo