#1
  1. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Feb 2004
    Posts
    597
    Rep Power
    15

    Problem on starting X


    Hi folks,


    OpenBSD 4.0

    After login as User and ran
    $ startx
    Code:
    Xauth: Creating new authroity file /home/satimis/.serverauth:19055
    it was hanging here

    Pressed
    ^c ^c (twice)
    X window started.

    On console;
    $ firefox &

    sometime it worked another time no. Pls adise how to fix the problem.

    TIA


    B.R.
    satimis
  2. #2
  3. Banned ;)
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2001
    Location
    Woodland Hills, Los Angeles County, California, USA
    Posts
    9,625
    Rep Power
    4247
    Sounds like xauth is hanging trying to create the .Xauthority file. Please check the following:
    1. Make sure that the following is set in /etc/ssh/sshd_config
    X11Forwarding yes
    (this is normally set to no by default, if you didn't select the running X option in the installer)
    2. Make sure the following is set in /etc/ssh/ssh_config
    ForwardAgent yes
    ForwardX11 yes

    Also do a sysctl -a | grep machdep and make sure that machdep.allowaperture = 2
    Up the Irons
    What Would Jimi Do? Smash amps. Burn guitar. Take the groupies home.
    "Death Before Dishonour, my Friends!!" - Bruce D ickinson, Iron Maiden Aug 20, 2005 @ OzzFest
    Down with Sharon Osbourne

    "I wouldn't hire a butcher to fix my car. I also wouldn't hire a marketing firm to build my website." - Nilpo
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Feb 2004
    Posts
    597
    Rep Power
    15
    Originally Posted by Scorpions4ever
    Sounds like xauth is hanging trying to create the .Xauthority file. Please check the following:
    1. Make sure that the following is set in /etc/ssh/sshd_config
    X11Forwarding yes
    (this is normally set to no by default, if you didn't select the running X option in the installer)
    # cat /etc/ssh/sshd_config | grep X11Forwarding
    Code:
    #X11Forwarding no
    #       X11Forwarding no
    Uncomment and change it to "yes"

    2. Make sure the following is set in /etc/ssh/ssh_config
    ForwardAgent yes
    ForwardX11 yes
    # cat /etc/ssh/sshd_config | grep ForwardAgent
    No printout

    # cat /etc/ssh/sshd_config | grep ForwardX11
    No printout

    Shall I create them??? TIA


    Also do a sysctl -a | grep machdep and make sure that machdep.allowaperture = 2
    # sysctl -a | grep machdep
    Code:
    machdep.console_device=ttyC0
    machdep.bios.diskinfo.0=bootdev = 0xa0000202, cylinders = 80, heads = 2, sectors = 18
    machdep.bios.diskinfo.128=bootdev = 0xa0000200, cylinders = 1023, heads = 255, sectors = 63
    machdep.bios.cksumlen=1
    machdep.allowaperture=2
    machdep.cpuvendor=AuthenticAMD
    machdep.cpufeature=396098559
    machdep.kbdreset=0
    "machdep.allowaperture=2" is there.


    B.R.
    satimis
  6. #4
  7. Banned ;)
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2001
    Location
    Woodland Hills, Los Angeles County, California, USA
    Posts
    9,625
    Rep Power
    4247
    Originally Posted by satimis
    # cat /etc/ssh/sshd_config | grep X11Forwarding
    Code:
    #X11Forwarding no
    #       X11Forwarding no
    Uncomment and change it to "yes"
    Also restart your sshd after this.


    Originally Posted by satimis
    # cat /etc/ssh/sshd_config | grep ForwardAgent
    No printout

    # cat /etc/ssh/sshd_config | grep ForwardX11
    No printout

    Shall I create them??? TIA
    Note for the above, I said to check /etc/ssh/ssh_config, not sshd_config
    Up the Irons
    What Would Jimi Do? Smash amps. Burn guitar. Take the groupies home.
    "Death Before Dishonour, my Friends!!" - Bruce D ickinson, Iron Maiden Aug 20, 2005 @ OzzFest
    Down with Sharon Osbourne

    "I wouldn't hire a butcher to fix my car. I also wouldn't hire a marketing firm to build my website." - Nilpo
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Feb 2004
    Posts
    597
    Rep Power
    15
    Hi Scorpions4ever,

    Note for the above, I said to check /etc/ssh/ssh_config, not sshd_config
    Oh, sorry. I made a mistake.

    Both of them were commented out. Change them as advised. Reboot PC. Problem seems gone. I'll come back to this forum should problem reoccurs. Tks.


    B.R.
    satimis

IMN logo majestic logo threadwatch logo seochat tools logo