#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2004
    Posts
    93
    Rep Power
    0

    permission denied on a file in freeBsd 4.11


    I have no knowledge of freebsd but i loaded it up and added a new user.

    I then worked out how to download from the net for files, I then su'd and went and downloaded the ati video driver i need for X , when I try to run it (./ati-driver-installer-8.16.20.run ) i get permission denied and it is really annoying me now, I have been trying to load it for 2 days !! , I have read the manual and that seems written in sanscrit for the newbie and is totally confusing , can anyone tell me what i need to do to get this to run please ?
  2. #2
  3. Banned ;)
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2001
    Location
    Woodland Hills, Los Angeles County, California, USA
    Posts
    9,607
    Rep Power
    4247
    Try this:
    chmod 755 ati-driver-installer-8.16.20.run
    ./ati-driver-installer-8.16.20.run

    The chmod line turns on run permissions for the file. Read man chmod for more details.
    Up the Irons
    What Would Jimi Do? Smash amps. Burn guitar. Take the groupies home.
    "Death Before Dishonour, my Friends!!" - Bruce D ickinson, Iron Maiden Aug 20, 2005 @ OzzFest
    Down with Sharon Osbourne

    "I wouldn't hire a butcher to fix my car. I also wouldn't hire a marketing firm to build my website." - Nilpo
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2004
    Posts
    93
    Rep Power
    0
    Originally Posted by Scorpions4ever
    Try this:
    chmod 755 ati-driver-installer-8.16.20.run
    ./ati-driver-installer-8.16.20.run

    The chmod line turns on run permissions for the file. Read man chmod for more details.
    AWESOME !! , I spent days reading the manual , enough to make a man cry in frustration, now I get write failed :file system full , god knows why , i only have BSD installed on a 120G hd . Sigh . This sure aint like windows where i can see everything : )

    But at least what you said worked for that I am gratefull.
  6. #4
  7. Banned ;)
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2001
    Location
    Woodland Hills, Los Angeles County, California, USA
    Posts
    9,607
    Rep Power
    4247
    Show me the output of the df command and also where you're running this ati-driver-installer-8.16.20.run command (type pwd to show the current directory). I'll bet you're doing something funky somewhere.
    Up the Irons
    What Would Jimi Do? Smash amps. Burn guitar. Take the groupies home.
    "Death Before Dishonour, my Friends!!" - Bruce D ickinson, Iron Maiden Aug 20, 2005 @ OzzFest
    Down with Sharon Osbourne

    "I wouldn't hire a butcher to fix my car. I also wouldn't hire a marketing firm to build my website." - Nilpo
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2004
    Posts
    93
    Rep Power
    0
    pwd = /root

    df =
    filesystem 1K blocks used avail cap mounted on
    /dev/ads0s1a 128990 128206 -9534 108% /
    /dev/ads0s1f 257998 20 237340 0% /tmp
    /dev/ads0s1g 116514412 1872844 105320416 2% /usr
    /dev/ad0s1e 257998 8640 228720 4% /var
    procfs 4 4 0 100% /proc

    sorry about the mess , but i cant access it from here to c/p
  10. #6
  11. Banned ;)
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2001
    Location
    Woodland Hills, Los Angeles County, California, USA
    Posts
    9,607
    Rep Power
    4247
    There's your problem.
    Code:
    filesystem 1K blocks used avail cap mounted on
    /dev/ads0s1a 128990 128206 -9534 108% /
    /dev/ads0s1f 257998 20 237340 0% /tmp
    /dev/ads0s1g 116514412 1872844 105320416 2% /usr
    /dev/ad0s1e 257998 8640 228720 4% /var
    procfs 4 4 0 100% /proc
    RULE NUMBER 1: NEVER download anything to the / partition (which is where /root is located). Always put your downloads in /usr/local/src or somewhere like that. Note that your /usr partition is only 2% full.
    Read man hier for more.
    There's a very good reason why the / partition is only supposed to be 100-128 MB or so in size. Only the basic tools to get the OS up and running should be here. Anything else should be put under the /usr partition.

    With that said, let's see about recovering your mess. (In all the below commands, you could substitute /usr/local/src/downloads or /usr/local/downloads or something else instead of /usr/local/src if you like).
    1. cd /usr/local/src
    If this doesn't work, then do mkdir -p /usr/local/src and try again.
    2. mv /root/ati-driver-installer-8.16.20.run /usr/local/src
    This moves the file from /root to /usr/local/src.
    3. Do another df here and make sure that the / partition usage has dropped. If it hasn't dropped right away, wait for a few mins and try again. It should drop below 100%.. If you have addtional files that you downloaded to /root, you should move those into /usr/local/src tree as well.
    4. [b]cd /usr/local/src[b]
    5. ./ati-driver-installer-8.16.20.run
    Up the Irons
    What Would Jimi Do? Smash amps. Burn guitar. Take the groupies home.
    "Death Before Dishonour, my Friends!!" - Bruce D ickinson, Iron Maiden Aug 20, 2005 @ OzzFest
    Down with Sharon Osbourne

    "I wouldn't hire a butcher to fix my car. I also wouldn't hire a marketing firm to build my website." - Nilpo
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2004
    Posts
    93
    Rep Power
    0
    Thanks , I guess funky wasn't the word !!. will do as you said, if that doesn't work will reinstall. I did actualy re-download it into a /home/mine/ directory and do what you previously told me to, and i get a ./ati-installer.sh: 90 Syntax error: Bad Substitution , so I dont think its going to install after all this effort which annoys the hell out of me.
  14. #8
  15. Banned ;)
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2001
    Location
    Woodland Hills, Los Angeles County, California, USA
    Posts
    9,607
    Rep Power
    4247
    Do an ls -l / and print the output here.
    I want to make sure that /home is not on the / partition . If it is, you'll still have the same problem of filling up the / partition again.
    Up the Irons
    What Would Jimi Do? Smash amps. Burn guitar. Take the groupies home.
    "Death Before Dishonour, my Friends!!" - Bruce D ickinson, Iron Maiden Aug 20, 2005 @ OzzFest
    Down with Sharon Osbourne

    "I wouldn't hire a butcher to fix my car. I also wouldn't hire a marketing firm to build my website." - Nilpo
  16. #9
  17. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2004
    Posts
    93
    Rep Power
    0
    Only way I can do that is on here ( its a huge list !! ) and i cant access it from here , for some reason I cant ssh into it . I could earlier but i dont know why not now. However I will do so as soon as i can get into it.
  18. #10
  19. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2004
    Posts
    93
    Rep Power
    0
    Sorry it took so long.

    I still cannot get that driver to install, so Ifear i will never get the chance to use FreeBSD , I still get that error .

    Games# ls -l /
    total 8676
    -rw-r--r-- 2 root wheel 802 Jan 21 2005 .cshrc
    drwx------ 2 root wheel 512 Sep 13 20:50 .mozilla
    -rw-r--r-- 2 root wheel 251 Jan 21 2005 .profile
    -r--r--r-- 1 root wheel 6117 Jan 21 2005 COPYRIGHT
    drwxr-xr-x 2 root wheel 1024 Sep 13 21:00 bin
    drwxr-xr-x 3 root wheel 512 Sep 13 21:02 boot
    drwxr-xr-x 2 root wheel 512 Sep 13 20:20 cdrom
    drwxr-xr-x 2 root wheel 512 Sep 13 20:20 cdrom1
    lrwxr-xr-x 1 root wheel 10 Sep 13 20:30 compat -> usr/compat
    drwxr-xr-x 3 root wheel 20992 Sep 13 22:06 dev
    drwxr-xr-x 2 root wheel 512 Sep 13 20:20 dist
    drwxr-xr-x 16 root wheel 2048 Sep 13 22:07 etc
    lrwxrwxrwx 1 root wheel 9 Sep 13 20:50 home -> /usr/home
    dr-xr-xr-x 2 root wheel 512 Sep 13 21:53 host
    -r-xr-xr-x 1 root wheel 4388756 Jan 21 2005 kernel
    -r-xr-xr-x 1 root wheel 4388756 Jan 21 2005 kernel.GENERIC
    drwxr-xr-x 2 root wheel 512 Jan 21 2005 mnt
    drwxr-xr-x 2 root wheel 4608 Sep 13 20:56 modules
    dr-xr-xr-x 2 root wheel 512 Sep 13 21:53 net
    dr-xr-xr-x 1 root wheel 512 Sep 13 22:07 proc
    drwxr-xr-x 2 root wheel 512 Sep 13 20:56 root
    drwxr-xr-x 2 root wheel 2048 Sep 13 21:00 sbin
    drwxr-xr-x 4 root wheel 1024 Sep 13 20:20 stand
    lrwxrwxrwx 1 root wheel 11 Sep 13 20:56 sys -> usr/src/sys
    drwxrwxrwt 7 root wheel 512 Sep 13 22:06 tmp
    drwxr-xr-x 17 root wheel 512 Sep 13 21:02 usr
    drwxr-xr-x 21 root wheel 512 Jan 21 2005 var
  20. #11
  21. Banned ;)
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2001
    Location
    Woodland Hills, Los Angeles County, California, USA
    Posts
    9,607
    Rep Power
    4247
    well, your home directory looks like a good place to do things because it is symlinked to /usr/home. BTW, are you sure you downloaded a freebsd driver installer. Would you please show me the link where you got the driver from. I suspect this thing is expecting a bash shell, not tcsh.
    Up the Irons
    What Would Jimi Do? Smash amps. Burn guitar. Take the groupies home.
    "Death Before Dishonour, my Friends!!" - Bruce D ickinson, Iron Maiden Aug 20, 2005 @ OzzFest
    Down with Sharon Osbourne

    "I wouldn't hire a butcher to fix my car. I also wouldn't hire a marketing firm to build my website." - Nilpo
  22. #12
  23. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2004
    Posts
    93
    Rep Power
    0
    Erm I cant now , I got absolutely fed up of it all and i decided to stick it on another machine with a nvidia card in , so that's now sorted out , kind of. Now I have another ! , I didn't realise Apache was installed on 5.4 , sooo I downloaded the latest from the web and installed it , then I couldn't get the web page to show so deleted it and I also deleted the original install as well without knowing it, however I cannot load it up again with sysinstall i get a error -1 or such.

    I really shouldn't tinker untill I read the book ( i did but its like sanscrit to me ) .

    Ignore that , I just reinstalled via ports so its ok now. Sigh.

IMN logo majestic logo threadwatch logo seochat tools logo