#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2000
    Location
    Los Angeles, California
    Posts
    102
    Rep Power
    15

    Samba Configuration


    I am hoping this thread is okay here.

    I just installed Samba on FreeBSD 4.5. This is my first time trying to configure it. I used the instruction found on http://www.bsdvault.net. All seems to have worked well, but I am running into problems (hence, this post).

    This is what is happening:

    I can access SWAT from my Windows XP computer.

    Samba seems to run fine when I am on the computer running Samba. In order words, if samba is running on localhost, I can run the sambaclient program on localhost and log in as user unix user and get dumped into my home directory.

    Windows XP shows the Samba Server under My Network Places: Workgroup. It seems it, but when I try double-clicking the Samba Server icon, I get a pop-up that reads: \\ComputerName not available. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. The account is not authorized to log in from this station.

    I am not sure what to do at this point. Funny thing is, I can see the Samba Server from windows, but trying to browse the connection gives me an error.

    Any ideas?

    Please help. Thanks in Advance....
    Edgar Castanedo
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2001
    Location
    Sydney
    Posts
    41
    Rep Power
    14

    might be a password problem


    I am not quite sure about XP but from Win98 on ward they are using encrypted password. If this is the case, you setup Windoze to use plain text or setup Samba to use password encryption.

    For the Windoze option, you have to install "/tools/mtsutil/ptxt_on.inf" from the Windoze CD.

    For the Samba option, you have to add "encrypt passwords = yes" in smb.conf and you have to create smbpasswd file.

    I hope this is your problem...
    % gdb core tzuchunc
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2000
    Location
    Los Angeles, California
    Posts
    102
    Rep Power
    15
    Well that was easy... It worked!

    Thanks for your help. Too cool. I owe you one.
    Edgar Castanedo
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2000
    Location
    Los Angeles, California
    Posts
    102
    Rep Power
    15

    another problem


    I am getting a strange problem now. This wasn't happening before, but when I redid my FreeBSD system and tried to set up Samba again, things worked a little differently.

    Now, for some strange reason, I can only connect to shares using only one username and password. I tried to connect to another share as another user, but can't seem to do this. Windows gives me an alert saying that there is already another user connected to this resource.

    Since I did it before, although I am not sure how I did it that first time, can someone help me out and explain to me how I can have different users connect to different shares?

    The reason for this is because I want each user to have access to their own files in their home directory.

    There are two users. Each one should have a share named after their home directory. I can only connect one at a time.

    Can someone help me out?

    Thanks In Advance....
    Edgar Castanedo

IMN logo majestic logo threadwatch logo seochat tools logo