#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    126
    Rep Power
    21

    /home not in /etc/fstab (regarding quotas)


    I've been trying to enable quota on my freebsd 6.0 box twice already and failing on both occassions. I've followed the steps in the handbook but I'm a bit confused.

    An entry for the /home directory is missing in the /etc/fstab (as specified in the handbook), because I'm trying to set disk quotas for the home directories. My question is, will it work if I set quota (userquota) to the root directory entry?

    I did that before and did an edquota for a user. The system hangs when I tried to ftp a file into that user's home directory, and also hangs when I ftp'ed a file to other home directory. Lastly, it also hangs when I run the command `quota username`. I checked the quota.user file if it existed, it does, at the root directory (I understand that it'll be located there by default).

    So far, I've already edited, compiled and installed (twice) my kernel to accomodate quota (added the option), and I've also already edited my /etc/rc.conf file to enable quotas. Basically, the next step would be to edit the /etc/fstab file, where I'm stuck.

    This is my /etc/fstab file:
    Code:
    # Device                Mountpoint      FStype  Options         Dump    Pass#
    /dev/ad0s1b             none            swap    sw              0       0
    /dev/ad0s1a             /               ufs     rw              1       1
    /dev/ad0s1e             /tmp            ufs     rw              2       2
    /dev/ad0s1f             /usr            ufs     rw              2       2
    /dev/ad0s1d             /var            ufs     rw              2       2
    /dev/acd0               /cdrom          cd9660  ro,noauto       0       0
    I'm running out of ideas how to set the quota, and I'm a bit cautious of editing the /etc/fstab file already since I've caused my box to fail to boot already...

    Note: I have a /dev/ad0s1c file in the /dev directory, not listed in the /etc/fstab file. Already tried mounting it with /home. It says operation not permitted. I've checked /var/log/messages for errors in mounting and whether fsck is required, but no error messages are logs. But I did run fsck anyway (w/o options) and mount it with /home again, still operation not permitted.

    Thanks.
    Err...
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2006
    Posts
    9
    Rep Power
    0
    Originally Posted by johnhardey
    I've been trying to enable quota on my freebsd 6.0 box twice already and failing on both occassions. I've followed the steps in the handbook but I'm a bit confused.

    An entry for the /home directory is missing in the /etc/fstab (as specified in the handbook), because I'm trying to set disk quotas for the home directories. My question is, will it work if I set quota (userquota) to the root directory entry?

    I did that before and did an edquota for a user. The system hangs when I tried to ftp a file into that user's home directory, and also hangs when I ftp'ed a file to other home directory. Lastly, it also hangs when I run the command `quota username`. I checked the quota.user file if it existed, it does, at the root directory (I understand that it'll be located there by default).

    So far, I've already edited, compiled and installed (twice) my kernel to accomodate quota (added the option), and I've also already edited my /etc/rc.conf file to enable quotas. Basically, the next step would be to edit the /etc/fstab file, where I'm stuck.

    This is my /etc/fstab file:
    Code:
    # Device                Mountpoint      FStype  Options         Dump    Pass#
    /dev/ad0s1b             none            swap    sw              0       0
    /dev/ad0s1a             /               ufs     rw              1       1
    /dev/ad0s1e             /tmp            ufs     rw              2       2
    /dev/ad0s1f             /usr            ufs     rw              2       2
    /dev/ad0s1d             /var            ufs     rw              2       2
    /dev/acd0               /cdrom          cd9660  ro,noauto       0       0
    I'm running out of ideas how to set the quota, and I'm a bit cautious of editing the /etc/fstab file already since I've caused my box to fail to boot already...

    Note: I have a /dev/ad0s1c file in the /dev directory, not listed in the /etc/fstab file. Already tried mounting it with /home. It says operation not permitted. I've checked /var/log/messages for errors in mounting and whether fsck is required, but no error messages are logs. But I did run fsck anyway (w/o options) and mount it with /home again, still operation not permitted.

    Thanks.

    Personally I'd quota the /usr partition. Just make sure there are no qutas set for root (not that there would be anyway)

IMN logo majestic logo threadwatch logo seochat tools logo