#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Posts
    1
    Rep Power
    0

    Access Database, Cold fusion MX, uploading files and utf-8 encoding


    We are using Access Database and Cold Fusion MX.
    The UTF-8 data works fine for sending, preserving, and retrieving international characters but does not work when trying to upload a text or image file.
    I followed all instructions for adding code to application.cfm
    <cfset setEncoding("URL", "UTF-8")>
    <cfset setEncoding("FORM", "UTF-8")>
    <cfcontent type="text/html; charset=UTF-8">
    and adding <cfprocessingdirective pageencoding="UTF-8"> to the top of pages.
    I keep getting an error when attaching the utf-8 code to the multipart/form-data ... see code
    <form method="post" name="hidform" enctype="multipart/form-data: charset=utf-8" action="create_tile.cfm">
    any help would be soooooo very much appreciated.
    Cheers,
  2. #2
  3. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Location
    MOV @R1, P1 ; RAM (40H) <= OCAH
    Posts
    18
    Rep Power
    0
    I believe that's because you're overriding your own directives ..

    with
    <cfset setEncoding("FORM", "UTF-8")>
    you're already forcing your forms to use utf-8 encoding .. you do not need to add

    <form method="post" name="hidform" enctype="multipart/form-data: charset=utf-8 " action="create_tile.cfm">

    i might be wrong ..

    regards,
    idss

IMN logo majestic logo threadwatch logo seochat tools logo