#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2004
    Posts
    41
    Rep Power
    14

    CF page stops executing, no error


    I have a page that pulls back approximately 794 rows of data. I loop over that data and pull back a small set of information from a remote webservice. However, the page just stops. No errors, nothing in the logs. If the dataset is smaller, say half the size then everything works fine. I'm assuming this is a timeout issue but no matter what I set the timeout to it still doesn't work. I've tried setting the timeout on the page and in CF admin and it makes no difference.

    Any ideas on where else I should look?
  2. #2
  3. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,307
    Rep Power
    970
    You can try putting some logging or cfoutput in the loop to try and figure out how far it gets before it stops. You can also try pulling a smaller set of data and slowly increase it to determine the cutoff point.

    Also, make sure you try it in Chrome or Firefox. Some versions of IE have "user friendly error" settings that stop the underlying error from being shown.
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2004
    Posts
    41
    Rep Power
    14
    Originally Posted by kiteless
    You can try putting some logging or cfoutput in the loop to try and figure out how far it gets before it stops. You can also try pulling a smaller set of data and slowly increase it to determine the cutoff point.

    Also, make sure you try it in Chrome or Firefox. Some versions of IE have "user friendly error" settings that stop the underlying error from being shown.
    If I limit the number of rows I can get some data back. However, I've done a bit more testing on the admin timeout settings and the page timeout.

    n the Coldfusion Administrator, if I set the timeout to 60 seconds or below it works fine. If I set it above 60 seconds pages will still time out after 60 seconds. Also, if I use the cfsetting on the page to increase the timeout past 60 seconds the page will still time out at 60 seconds. If I set the time out on the page below 60 seconds it works as expected.

    Basically anything over 60 seconds in the administrator or on the page is ignored.

    I've never seen this type of behavior before. We're running CF11.
  6. #4
  7. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,307
    Rep Power
    970
    Are you setting the timeout at the application level, using applicationTimeout in an Application.cfc or Application.cfm file?

IMN logo majestic logo threadwatch logo seochat tools logo