#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Posts
    2
    Rep Power
    0

    ColdFusion / Frame Problem


    I have a strange problem w/a page I am working on. The site is built in CF and utilizes frames. When a user navigates through the site everything works fine
    (ex. http://www.batson-cook.com/webcams/ )
    but when I go to a specific URL
    (ex. http://www.batson-cook.com/webcams/p...?project=10303 )
    the bottom frame opens into a new window. How do I make it where this frame never opens into a new window?

    Here is the code that I am currently using:

    <html>
    <head>
    <title>Batson-Cook Home Page</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    </head>
    <frameset rows="*,45" frameborder="0" border="0" framespacing="0">
    <frame name="mainFrame" src="/webcams/project_detail.cfm?
    project=<cfoutput>#project#</cfoutput>" frameborder="no" marginwidth="0"
    marginheight="0" noresize scrolling="yes">
    <frame name="bottomFrame" scrolling="no" noresize src="../bottom_frame.cfm"
    marginwidth="0" marginheight="0" frameborder="NO" noresize>
    <frame src="/webcams/UntitledFrame-1"></frameset>
    <noframes>
    <body bgcolor="#FFFFFF" text="#000000">
    Your browser does not support frames.
    </body>
    </noframes>
    </html>

    Any help is greatly appreciated and thx in advance...
    Last edited by deogee151; November 24th, 2003 at 04:22 PM.
  2. #2
  3. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,273
    Rep Power
    968
    I see this when I view the page source...I'd say this Javascript is the problem:

    <script>
    z = window.open('','bottomFrame');
    z.location.href='../bottom_frame.cfm'
    </script>
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Posts
    2
    Rep Power
    0

    Unhappy


    That was the same thing that I thought as well but I commented out the script and was still getting the footer file opening into a new window....
  6. #4
  7. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,273
    Rep Power
    968
    Well when I look at the site, most of it loads the bottom frame correctly. But when I look at the link you gave it still opens in a new window, and I still see this in the source code. It's not commented out...I'm no Javascript guru but this sure looks like it would open a new window to me:

    <script>
    z = window.open('','bottomFrame');
    z.location.href='../bottom_frame.cfm'
    </script>


    I'm not sure what to tell you except that the problem is absolutely some sort of Javascript or frame issue and is definitely not a CF problem...let us know what you find out.

IMN logo majestic logo threadwatch logo seochat tools logo