#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Location
    the Great Byte north
    Posts
    2
    Rep Power
    0

    Intermittent CFMAIL Success


    I have an action script which posts form data to my db and then creates a summary of this data and uses a cfmail tag to email it to the accounting section for payment.

    This script worked fine in development but now the cfmail portion does not want to work. I have done a packet trace on this script and it seems that the CF server is not trying to contact the email server (Exchange).

    What is really throwing me is that I have similar scripts, same server, same folder, that work properly every time. This makes me almost 100% sure that relaying is turned on and not the issue here.

    Has anyone come across this type of problem and if so, what steps did you take to correct it?
  2. #2
  3. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,243
    Rep Power
    967
    If the other CFMAILs in the same directory work, can you verify that EVERYTHING is the same in the CFMAIL tag compared with the one that is failing?

    Also, if you look in the CF Admin logs, under mail, do you see anything helpful that might explain why it is failing?
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Location
    the Great Byte north
    Posts
    2
    Rep Power
    0

    solved


    Thanks kiteless.

    It was a malformed email address in the FROM portion. What threw me was that I was using the word "Dispatch" in another script and it works fine. I emailed our email administrator and he confirms that there is a valid address associated with that word. No wonder it worked!

    I put a valid address in and this worked as it is supposed to.

    DOH! Should have seen that but I stared at it too long....

    Thanks again.

IMN logo majestic logo threadwatch logo seochat tools logo