#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Location
    Florida
    Posts
    21
    Rep Power
    0

    problem linking to .cfm file that contains mail script


    I do not know cold fusion at all. And I have
    struggled and have come up with nothing. All
    I needed to do was edit the form on the page
    and of course the mail script.

    I saved it and uploaded. When I click on the
    link to go to the email page. My browser wants
    to download the file!(Unless I completely remove
    the mail script at the top, which defeats the purpose).

    You can see what I mean by going to

    http://www.minid.com/cfopreview/default.cfm

    Click on "sign up for newsletter".

    I tried opening it in a blank window and quickly
    stopping the page load. When I hard refresh..I get
    the page's script..inlcuding the Cold Fusion script
    not just the HTML ??!!!



    Below is what was originally provided to me.
    I did move the include file "header.cfm" into the
    <body> because it is a image banner and put the
    style.cfm ( a css style) include to the <head> tag.

    Can somebody tell me what I might be doing wrong??
    I hope I provided enough info, let me know if not.
    Thanks so much in advance.


    Code:
    <cfif ParameterExists(dosignup)>
    <cfif #rdoSubscribe# is "subscribe">
    <cfmail to="eanicklaus@website.com" from="#emailaddress#" subject="subscribe newsletter
     #emailaddress#">
    subscribe newsletter #emailaddress#
    </cfmail>
    <cfset tMSG = "#emailaddress# has been added to the Newsletter Mailing List">
    <cfelse>
    <cfmail to="eanicklaus@website.com" from="#emailaddress#" subject="unsubscribe newsletter #emailaddress#">
    unsubscribe newsletter #emailaddress#
    </cfmail>
    <cfset tMSG = "#emailaddress# has been removed from the Newsletter Mailing List">
    </cfif>
    
    
    </cfif>
    
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    
    <html>
    
    
    <cfinclude template="style.cfm">
    
    <cfinclude template="header.cfm">
    <head>
    	<title>Input your Email for timely updates of Networking Events</title>
    </head>
    <body>
    
    and so on and so forth.....
  2. #2
  3. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,265
    Rep Power
    968
    What version of CF are you using?

    If you remove the mail tags from the code does it still fail?
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Location
    Florida
    Posts
    21
    Rep Power
    0
    Thanks for your reply kiteless,

    I have no idea what version. How to you test that?
    If I completely remove the Mail script from the top and start the page with the Doctype line. It will display.
  6. #4
  7. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Location
    Florida
    Posts
    21
    Rep Power
    0
    Do you think it may be the server I am temporarily testing the page on???
  8. #5
  9. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,265
    Rep Power
    968
    Originally posted by eanicklaus
    Thanks for your reply kiteless,

    I have no idea what version. How to you test that?
    If I completely remove the Mail script from the top and start the page with the Doctype line. It will display.
    You can look in the ColdFusion Administrator. Or you can output the variables:

    Server.ColdFusion.ProductVersion
    Server.ColdFusion.ProductLevel
    Server.ColdFusion.ProductName
  10. #6
  11. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,265
    Rep Power
    968
    Originally posted by eanicklaus
    Do you think it may be the server I am temporarily testing the page on???
    Honestly I'm not sure. The only time I've seen this happen is if the ColdFusion Server is not properly configured to serve up .cfm pages. But as far as I can tell, other CF pages work on the server. Is more than one server being used?
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2001
    Location
    Washington DC, USA
    Posts
    156
    Rep Power
    14
    That's likely definitely the problem, either that the server doesn't support ColdFusion at all or it's improperly configured. CF support is rare on most web hosts so it's doubtful it'll work on just "any old server"


    -Cliff

IMN logo majestic logo threadwatch logo seochat tools logo