#1
  1. No Profile Picture
    http://stealthwd.ca
    Devshed Novice (500 - 999 posts)

    Join Date
    Dec 2005
    Posts
    691
    Rep Power
    201

    Page not finishing loading - coldfusion and htaccess bug?


    We have htaccess set up to automatically look for index.cfm first when hitting a directory. If you go to, say, www.example.com/dir/index.cfm, the page will load fine, but www.example.com/dir/ will not finish loading the page. If you look at the source, not all the html was loaded.

    This appears to happen randomly, we've had it happen under both CF6 and CF7 on different servers (all Windows+Apache), but it doesn't happen with .htm/.html/.php/other types of files.

    Is anyone aware of an issue with Coldfusion parsing and htaccess? Thanks!
  2. #2
  3. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,286
    Rep Power
    968
    htaccess is purely a web-server feature. ColdFusion has no idea what that even is, as far as it is concerned it is just another text file.

    The fact that the page is loading at all means CF is actually getting the request for processing, so I would suspect that something else is wrong, probably some kind of server or ColdFusion configuration issue. What that might be, though, I really can't say. I've used CF on Apache sites that have htaccess files and haven't had any problems. I know that doesn't help you a great deal, but at least it shows that what you're trying to do should normally work.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2013
    Posts
    2
    Rep Power
    0
    I am experiencing this exact same issue with ColdFusion on IIS 7.5 using URL Rewrite module.

    The page never finished loading, and not all of the HTML appears in the source code.

    Did you manage to find a solution to this problem? I'm totally stuck and out of ideas
  6. #4
  7. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,286
    Rep Power
    968
    If it works correctly when you turn off the rewrite module, you probably want to ask the folks who develop the module.

IMN logo majestic logo threadwatch logo seochat tools logo