#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2013
    Posts
    2
    Rep Power
    0

    Unhappy ColdFusion with IIS URL Rewrite - Page never finishes loading


    I am running CF10 on IIS 7.5 with URL Rewrite module installed.

    All the rewrite rules work perfectly and ColdFusion is returning the correct pages. In order to get the page displayed in the browser I have to manually set the 'content-length' value in Application.cfc like this:

    Code:
    <cfcomponent>
    <cffunction name="onRequestEnd">
    <cfheader name="Content-Length" value="#getPageContext().getCFOutput().getBuffer().size()#" />
    </cffunction>
    </cfcomponent>
    Without this code the browser does not display the page. However, even though it is now displaying the page, it is not doing it correctly. The page never finishes loading fully and not all of the HTML content seems to be on the page.

    I have tried to add a <cfflush> tag after setting the 'content-length' but it makes no difference. I don't understand why this is happening but I know that it has happened to someone else who was using htaccess: http://forums.devshed.com/coldfusion...ug-575906.html

    Can anyone please help?
  2. #2
  3. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,265
    Rep Power
    968
    As I said in the other thread, if it works correctly with the rewrite module turned off/disabled/uninstalled, then the issue has to be in the rewrite module. Which would mean the authors of the module would really be the only ones who might know what the problem is.
  4. #3
  5. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,265
    Rep Power
    968
    If you installed the module AFTER installing CF, it could also be worth re-running the CF web connector tool. It's possible the rewrite module stepped on the CF ISAPI module somehow.
  6. #4
  7. No Profile Picture
    Moderator

    Join Date
    Jun 2002
    Location
    Raleigh, NC
    Posts
    5,265
    Rep Power
    968
    One other option, if you're on CF 10, it may be worth making sure you're on the latest hotfix: http://blogs.coldfusion.com/post.cfm...0-0-1-released

IMN logo majestic logo threadwatch logo seochat tools logo