#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2013
    Posts
    28
    Rep Power
    0

    How to use full memory | How to reduce Hardware Reserved memory


    I am not sure its a right place for posting this thread or not (may be it goes to motherboard section)!

    I was upgrading a computer which is Lenovo 3000 Series J200 9690 7KU. It came with 2GB RAM and now I want it to work its maximum capacity of 4GB, so I have used two 2GB ram and it shows that Installed Memory (RAM): 4.00GB (2.87 GB usable)

    so going to "Resource Monitor" I found that "Hardware Reserved" portion got my 1161MB of ram :O

    now how can I reduce it?

    Just to add I have googled the problem and found a suggestion over and over again is to go to msconfig->boot->advanced settings-> maximum memory and uncheck it.

    But in my case its not working at all. I tried checking/unchceking allocating a fixed memory there, but it didnt work.

    Thanks in advance
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Oct 2009
    Location
    Nebraska, USA
    Posts
    887
    Rep Power
    276
    hardware reserved memory is not adjustable thru the OS.
    I assume you are running 32bit OS. In most cases that "usable memory" figure is between 3gb and 3.5gb, so, your 2.87gb IS a bit on the low side.

    If you want to release some of that "reserved memory", the only option I know of is to go into your BIOS and turn OFF any hardware that you don't use and see if it gives you back any memory...but, even with that, the most you will ever be able to use will be absolute maximum of 3.5gb for a 32bit OS.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2013
    Posts
    28
    Rep Power
    0
    I am using 64bit windows 7 operating system
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2006
    For your specific model the type of RAM you need is as follows (source):

    Memory:
    DDR2 PC2-5300
    Memory Type: DDR2 PC2-5300, DDR2 (non-ECC)
    Maximum Memory: 4GB
    Slots: 2

    Verify you are using compatible RAM (most likely are since the computer boots).

    The latest BIOS version released for that model is version 2TKT53A. Verify your BIOS is up-to-date, and if not, download it here.

    If all else fails, try resetting the BIOS to factory defaults; don't worry this won't "break" anything.
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2013
    Posts
    28
    Rep Power
    0
    Originally Posted by seack79
    For your specific model the type of RAM you need is as follows (source):

    Memory:
    DDR2 PC2-5300
    Memory Type: DDR2 PC2-5300, DDR2 (non-ECC)
    Maximum Memory: 4GB
    Slots: 2

    Verify you are using compatible RAM (most likely are since the computer boots).

    The latest BIOS version released for that model is version 2TKT53A. Verify your BIOS is up-to-date, and if not, download it here.

    If all else fails, try resetting the BIOS to factory defaults; don't worry this won't "break" anything.
    Thanks .. but I have tried this thing also. unfortunetely its not working ether. I dont know exactly what is wrong with it. I know that RAM is ok, BIOS is uptodate, but there is something missing.
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2006
    Here is a great read on what you may be experiencing. It gives some additional things to try; some of which you have already done, and others you have not tried yet (don't know if they're applicable to your situation though).

    http://support.microsoft.com/kb/978610

    As Don said, there are several things that can prevent the OS from having access to all the physical RAM installed.

    "This is expected behavior on computers that are running Windows 7. The reduction in available system memory depends on the configuration of the following:

    1. The devices that are installed in the computer and the memory that is reserved by those devices
    2. The ability of the motherboard to handle memory
    3. The System BIOS version and settings
    4. The version of Windows 7 that is installed (For example, --Windows 7 Starter Edition only supports 2 GB of installed memory.)
    5. Other system settings"
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2014
    Posts
    1
    Rep Power
    0
    Originally Posted by virus_s7
    Thanks .. but I have tried this thing also. unfortunetely its not working ether. I dont know exactly what is wrong with it. I know that RAM is ok, BIOS is uptodate, but there is something missing.
    I have used a notebook with 4 GB RAM and Windows 7 Ultimate 32 bits. It has the same problem. It shows 4 GB RAM installed and only 2.87 GB usable.

    Resource monitor shows 1154 MB hardware reserved RAM.

    I installed Linux Ubuntu 32 bits (dual boot with GRUB) and the same problem. No matters what OS I use, the usable RAM is allways 2.87 GB.

    I replaced later the Linux UBUNTU 32 bits with Linux Mint 64bits and it solved the problem when running Linux, and the problem appears when running Windows. So it must be related to the 32 bits.

    The same hardware, the same BIOS configuration, the problem is present in 32 bits OS.

    I tried with PAE enabled in Windows but didn't change anything.

    If you have more than 3GB, try to use 64 bits OS.
  14. #8
  15. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2015
    Location
    South Wales, UK
    Posts
    1
    Rep Power
    0

    Lightbulb


    Hi all, this is my first thread, so be gentle with the noob! :P

    Anyway, I have had a similar problem with my computer and the "Hardware Reserved RAM" in Windows 7 (64 Bit). After much research I found a solution which did work for me.

    Please see below:-

    1. Run "Regedit" (Type in "Regedit" in search after clicking Windows Key)

    2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlDSet\Control\Session Manager\Memory Management

    3. Find "ClearPageFileAtShutdown" and Double Click

    4. Type in 1 and Press Enter

    5. Double Click "ClearPageFileAtShutdown", Type in 2 and Press Enter

    6. Double Click "ClearPageFileAtShutdown", Type in 0 and Press Enter

    7. "Shutdown" Computer (Do not Restart as this does not work)

    8. Power up computer and you should have Full use of of the computers RAM

    A big Thank you to randygardener with his YouTube video for the above solution

    The video can be found here www(dot)youtube.com/watch?v=eXRtyFok64g

    Please note the video is not the greatest in quality but like I said it worked for me

    Hope the above is some help.
  16. #9
  17. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2015
    Posts
    3
    Rep Power
    0
    I'd been searching on and off for ages for a working solution to this problem and this solution worked first time, I now have an extra 8GB of RAM to work in! Nice one mrscaled (and randygardener).
  18. #10
  19. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2015
    Posts
    3
    Rep Power
    0
    Sorry, mrscaleh not mrscaled
  20. #11
  21. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2015
    Posts
    3
    Rep Power
    0

    Unhappy Temp solution


    Unfortunately, it now appears that this is only a temporary solution. My 8GB has gone back into Hardware Reserved.

IMN logo majestic logo threadwatch logo seochat tools logo