#1
  1. not a fan of fascism (n00b)
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Feb 2003
    Location
    ct
    Posts
    2,756
    Rep Power
    95

    router needs to be reset at least once a week


    i have a netgear router that is hosting 3 computers on my LAN. the netgear router itself is behind a linksys router which is then connected to the net. (yes i know i should just get a HUB and have one of my boxes do NAT for all my comps and one of these days i will ). the problem is that at least once a week all my boxes behind the netgear will lose their internet connection. If i turn them all off and unplug/plug the router they are fine...for a week that is. Watching tcpdump i've discovered this:
    my comps are unable to resolve the hardware address of my router, i.e. the ARP requests go out to the router but the ARP replies dont come back in. Now im pretty sure i can just stick something into the ARP cache or something along those lines, but i want to know why this is happening. Any ideas?
  2. #2
  3. not a fan of fascism (n00b)
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Feb 2003
    Location
    ct
    Posts
    2,756
    Rep Power
    95
    ehh problem was staring me right in the face! whenever i let my robot run for more than 1/2 an hour, this happens... DOS'ing myself, lol The robot generates a large number of RESET packets; so i guess my crudola router gets its buffers overran and craps out. Does anyone have any info on how i could possibly ascertain what this limit is? i think its pretty sh1tty it can only handle that few packets. THe robot send out requests once per second...

IMN logo majestic logo threadwatch logo seochat tools logo