Ok, i was playing my game FF XI (online) and i had winamp playing music in the background. all of a sudden the music started to studder, then it went completly off. a little bit after that my main HD started clicking. so i exited the game to shut the computer down and right as i exited the game my comp froze. i reboted it and nothing came up, just a black screen but i heard everything warm up and then the hard drive started to click. so i went out and bought a new hard drive because i thought old one was dead. i was just starting the win 2k instalation and then i got a disk error. so i put my old hd back in the comp, tryed switching out video cards to see if that worked, and it didn't. took out the sound card, didn't work. tryed using a diffrent power supply that didn't fix it, so i hooked my old HD to the comp im useing now and i was able to boot streight into windows. a little befor my hd started makeing the clicking the cpu fan started making some weird noises and i had to actually pull the fan up a bit to get it to stop, mind you it was only the fan not the heat sink. ok the specs on my comp are:
Motherboard: Asus A7V333
Processor: AMD Athlon 2400+
Ram: 512
Video Card: GeForce 4 Ti 4800
Sound Card: Creative Audigy XGamer
Hard Drive: Western Digital 120gig 8mb cash
Power Supply: Enermax Whisper
OS: Windows 2000

right now, i can get in to bios but i have to kinda get it to reconise the hd, but when it starts up it will get to the windows picture and freeze. it still is making that clicking noise, Please help i want my computer back T_T