#1
  1. meester luva luva
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Mar 2003
    Posts
    2,715
    Rep Power
    29

    common cause of non-clickable text?


    Is there a common cause of non-clickable text? I mean that on the suckerfish style menus I can't click on text in the link items. I thought it was a z-indexing issue but apparently not. I have encountered this problem many times now and am not sure how to fix it.
  2. #2
  3. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2004
    Posts
    219
    Rep Power
    15
    sounds like an overlapping <div> problem, check to make sure your hierarchy isn't mixed up
  4. #3
  5. meester luva luva
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Mar 2003
    Posts
    2,715
    Rep Power
    29
    Hmm, can you see any errors with this? It looks fine to me. Thanks

    PHP Code:
    <div id="navigation">
                <div id="sub_navbar">
                    <a href="introducers.php" accesskey="I">Introducers</a> | 
                    <a href="profile.php" accesskey="P">Profile</a> | 
                    <a href="equifax.php" accesskey="E">Equifax</a> |
                    <a href="powerofattorney.php" accesskey="O">Power of Attorney</a> |
                    <a href="newsandpress.php" accesskey="N">News &amp; Press</a> | 
                    <a href="contactus.php" accesskey="C">Contact</a> | 
                    <a href="links.php" accesskey="L">Links</a> | 
                    <a href="sitemap.php" accesskey="S">Sitemap</a> | 
                    <a href="index.php" accesskey="H">Homepage</a>
                </div><!-- END sub_navbar -->
                
                <div id="mainnav">
                      <ul id="nav">
                        <!--<li id="nav-tips"><a href="toptips.php" accesskey="T">Top Tips</a></li>-->
                        <li id="nav-insurance current" class="leftbg"><a href="sipps.php" accesskey="V">SIPPS</a></li>
                        <li class="leftbg"><a href="legalservices.php" accesskey="G">Legal Services</a></li>
                        <li class="leftbg"><a href="insurance.php" accesskey="R">Insurance</a></li>
                          <li class="leftbg" id="nav-apply"><a href="mortgage_applicationform.php" accesskey="A">Apply Now</a></li>
                        <li class="leftbg" id="nav-calculator"><a href="mortgage_calculator.php" accesskey="M">Mortgage Calculator</a></li>
                        <li class="leftbg" id="nav-products"><a href="currency_list.php" accesskey="D">Currency</a>
                            <ul class="submenu">
                                <?php 
                                
    while ($row_currency = @mysql_fetch_array($result_currency)) {
                                echo 
    "<li class=\"submenu\"><a href=\"currency_details.php?uid=" $row_currency["uid"] . "\">" $row_currency["productname"] . "</a></li>";
                                }
                                
    ?>
                            </ul>                
                        </li>
                        <li id="nav-products" class="leftbg"><a href="mortgage_products.php" accesskey="D">Mortgages</a>
                            <ul class="submenu">
                                <?php 
                                
    while ($row_mortgage = @mysql_fetch_array($result_mortgage)) {
                                echo 
    "<li class=\"submenu\"><a href=\"mortgage_details.php?uid=" $row_mortgage["uid"] . "\">" $row_mortgage["name"] . "</a></li>";
                                }
                                
    ?>                        
                            </ul>                    
                        </li>    
                  </ul>
                  <div id="subnavbg"></div>
      </div><!-- END mainnav -->
  6. #4
  7. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2004
    Posts
    219
    Rep Power
    15
    Originally Posted by ralphuk100
    Hmm, can you see any errors with this? It looks fine to me. Thanks

    PHP Code:
    <div id="navigation">
                <div id="sub_navbar">
                    <a href="introducers.php" accesskey="I">Introducers</a> | 
                    <a href="profile.php" accesskey="P">Profile</a> | 
                    <a href="equifax.php" accesskey="E">Equifax</a> |
                    <a href="powerofattorney.php" accesskey="O">Power of Attorney</a> |
                    <a href="newsandpress.php" accesskey="N">News &amp; Press</a> | 
                    <a href="contactus.php" accesskey="C">Contact</a> | 
                    <a href="links.php" accesskey="L">Links</a> | 
                    <a href="sitemap.php" accesskey="S">Sitemap</a> | 
                    <a href="index.php" accesskey="H">Homepage</a>
                </div><!-- END sub_navbar -->
                
                <div id="mainnav">
                      <ul id="nav">
                        <!--<li id="nav-tips"><a href="toptips.php" accesskey="T">Top Tips</a></li>-->
                        <li id="nav-insurance current" class="leftbg"><a href="sipps.php" accesskey="V">SIPPS</a></li>
                        <li class="leftbg"><a href="legalservices.php" accesskey="G">Legal Services</a></li>
                        <li class="leftbg"><a href="insurance.php" accesskey="R">Insurance</a></li>
                          <li class="leftbg" id="nav-apply"><a href="mortgage_applicationform.php" accesskey="A">Apply Now</a></li>
                        <li class="leftbg" id="nav-calculator"><a href="mortgage_calculator.php" accesskey="M">Mortgage Calculator</a></li>
                        <li class="leftbg" id="nav-products"><a href="currency_list.php" accesskey="D">Currency</a>
                            <ul class="submenu">
                                <?php 
                                
    while ($row_currency = @mysql_fetch_array($result_currency)) {
                                echo 
    "<li class=\"submenu\"><a href=\"currency_details.php?uid=" $row_currency["uid"] . "\">" $row_currency["productname"] . "</a></li>";
                                }
                                
    ?>
                            </ul>                
                        </li>
                        <li id="nav-products" class="leftbg"><a href="mortgage_products.php" accesskey="D">Mortgages</a>
                            <ul class="submenu">
                                <?php 
                                
    while ($row_mortgage = @mysql_fetch_array($result_mortgage)) {
                                echo 
    "<li class=\"submenu\"><a href=\"mortgage_details.php?uid=" $row_mortgage["uid"] . "\">" $row_mortgage["name"] . "</a></li>";
                                }
                                
    ?>                        
                            </ul>                    
                        </li>    
                  </ul>
                  <div id="subnavbg"></div>
      </div><!-- END mainnav -->
    your "<div id="navigation"> is never closed... give that a shot
  8. #5
  9. meester luva luva
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Mar 2003
    Posts
    2,715
    Rep Power
    29
    Thanks for the suggestion. It is actually closed. I just forgot to paste it in. My bad.
  10. #6
  11. Contributing User
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Mar 2005
    Location
    Tír na nÓg
    Posts
    1,199
    Rep Power
    182
    Why isn't all your code coloured? It's all in the php code tag!
    There's something wrong after you close your first php section. I'm not versed enough to know what it is, but colour stops there. Where's your css code?
    Last edited by prcAdap; December 1st, 2005 at 06:57 AM.
  12. #7
  13. meester luva luva
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Mar 2003
    Posts
    2,715
    Rep Power
    29
    It stops there because the LI tags are PHP generated, not HTML. I think.

    I have solved the issue now. The height of the subnav LI's was too great.

    Thanks for all the help.
  14. #8
  15. Contributing User
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Mar 2005
    Location
    Tír na nÓg
    Posts
    1,199
    Rep Power
    182
    I just nipped over to the php forum and grabbed this:
    PHP Code:
    <?php echo $record2'info' ];?>
    The opening and closing tags are both blue, yours aren't, but I can't spot what it is though . . . sorry.
  16. #9
  17. Contributing User
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Mar 2005
    Location
    Tír na nÓg
    Posts
    1,199
    Rep Power
    182
    kk, np, wish I had been more help!

IMN logo majestic logo threadwatch logo seochat tools logo