#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2007
    Posts
    5
    Rep Power
    0

    CSS problem with Firefox & Opera


    This page - juicyart dot net / test.html (sorry I can't post URLs yet) - displays fine in IE, but not in Firefox or Opera. In those two browsers the top image and white background of the container div won't display. The top image displays, but not completely - only about half of it shows up. Any suggestions? I can't figure this out for the life of me and W3C validates my css as valid so I'm at a loss.
  2. #2
  3. Thanks Johnny Hart (BC) R.I.P.

    Join Date
    May 2003
    Location
    Dallas
    Posts
    5,262
    Rep Power
    1960
    Let's start with this:
    Code:
    .content {
      margin-left: 180px;
      margin-top: 178px;
      border-left: 1px dotted #999999;
      padding-left: 8px;
      font: 12px Arial, Helvetica, sans-serif;
      padding-right: 5px;
      }
    
    #container {
      overflow: hidden;
    	BORDER-RIGHT: #222 1px dotted;
    	MARGIN: 0px auto;
    	BORDER-LEFT: #222 1px dotted;
    	WIDTH: 750px;
    	}
    Why do you have #container in three different places in the css?

    cheers,

    gary
    There are those who manage to build a web site without knowing what they're doing; thereby proving to themselves they do, indeed, know what they're doing.

    My html and css workshop, demos and tutorials.
    Ask a better question, get a better answer.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2007
    Posts
    5
    Rep Power
    0
    Well I got rid of the multiple container tags - not sure why there were 3 - and put the information from all of them into one. That fixed it. However I'm also having a problem with some div/layer showing up in Firefox behind the Current Project heading with a gray border. I've searched and searched and searched my code but can't find what is labeled "Layer2" in Firefox's DOM inspector. Any suggestions?
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2007
    Posts
    5
    Rep Power
    0
    scratch that, after pressing refresh a few dozen times it finally went away.

IMN logo majestic logo threadwatch logo seochat tools logo