#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    6
    Rep Power
    0

    CSS hover Safari image not showing


    I have an image gallery, that when the thumbnail is hovered over a larger image appears. This works fine in Firefox and IE but not in Safari. I have validated my code and css.

    The gallery is at http://www.briandobson.com.au/sthaust.html
    Code:
    <tr>
            <td valign="top">Boat Harbour, Goolwa<br />
              75  x 35cm <br />
              $720</td>
            <td valign="top">&nbsp;</td>
            <td>
    <a class="thumbnail" href="#"><img src="SthAust/thumbs/Boat-Harbour---Goolwa.jpg" alt="Boat Harbour, Goolwa" width="200" height="46" />
    <span>
    <img src="SthAust/Boat-Harbour---Goolwa.jpg" alt="Boat Harbour, Goolwa" width="775" height="248" />
    </span>
    </a> 
             </td>
    </tr>

    CSS is in the head and separate styles.css

    Code:
    .thumbnail img {
    	border: 1px solid white;
    }
    .thumbnail:hover {
    	background-color: transparent;
    	float: left;
    }
    .thumbnail:hover img {
    	border: 1px solid white;
    }
    .thumbnail span {
    	position: absolute;
    	background-color: white;
    	padding: 1px;
    	left: -1000px;
    	border: 1px solid black;
    	visibility: hidden;
    	color: black;
    	text-decoration: none;
    	display: block;
    }
    .thumbnail span img {
    	border-width: 1px;
    }
    .thumbnail:hover span {
    	visibility: visible;
    	background: top;
    	left: 0px;
    	z-index: 50;
    }
    With thanks
    Angela
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    6
    Rep Power
    0

    Puzzled by Safari


    Would someone please inform me if I have worded my question incorrectly?

    26 people have checked my problem but not one person has left me any feed back re CSS hover Safari image not showing

    Am I just not seeing an obvious answer or is there a problem that I am unaware of.

    I did search the forums for Safari help but could not find an answer to my problem.

    Thanks Angela
  4. #3
  5. Eager to learn
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Jan 2009
    Location
    Maryland, USA
    Posts
    2,230
    Rep Power
    2179
    Please don't make new threads. There are only so many people on this forum. I'll take a look at your thread tomorrow.. (technically that's 2 minutes away for me..)
    "Quality of responses may vary. I reserve the right to change my mind for any reason what-so-ever without admitting I was wrong. I'd prefer to change your mind however, it's easier on my ego". - jwdonahue

    "so no-one has actually bothered to post an original quote ? what's wrong with making up your own?"
    - marnixR
  6. #4
  7. Eager to learn
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Jan 2009
    Location
    Maryland, USA
    Posts
    2,230
    Rep Power
    2179
    I get this when I visit your site

    An error occured retreiving bizcard information: Could not find domain briandobson.com.au/sthaust.html
    "Quality of responses may vary. I reserve the right to change my mind for any reason what-so-ever without admitting I was wrong. I'd prefer to change your mind however, it's easier on my ego". - jwdonahue

    "so no-one has actually bothered to post an original quote ? what's wrong with making up your own?"
    - marnixR
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    6
    Rep Power
    0

    thanks for looking


    Originally Posted by EricReese
    I get this when I visit your site
    Hi Eric,

    Not sure what is happening there. I have contacted the hosting company re this error, but it doesn't occur everytime the site is accessed.

    Are you able to explain to me if the Safari browser behaves differently to IE8 and Firefox 3.0.9 when a thumbnail image is hovered over.

    I am trying to get an image gallery, that behaves as expected in IE and Firefox, to work in Safari. I just can't get the hover to work in the Safari browser.

    I just accessed the site without any problems thru the google chrome browser.


    Kind regards
    Angela
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    6
    Rep Power
    0
    Originally Posted by EricReese
    Please don't make new threads. There are only so many people on this forum. I'll take a look at your thread tomorrow.. (technically that's 2 minutes away for me..)
    Sorry Eric,

    I am new to this forum stuff. I was disappointed when 26 people had viewed my problem but not one had left a response.

    I thought maybe I had done something wrong according to the forum rules and people were ignoring my question, due to something stupid that I had done.

    Thank you so much for taking a look
    kind regards
    Angela
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    6
    Rep Power
    0
    Originally Posted by avonti
    Hi Eric,

    Not sure what is happening there. I have contacted the hosting company re this error, but it doesn't occur everytime the site is accessed.

    Are you able to explain to me if the Safari browser behaves differently to IE8 and Firefox 3.0.9 when a thumbnail image is hovered over.

    I am trying to get an image gallery, that behaves as expected in IE and Firefox, to work in Safari. I just can't get the hover to work in the Safari browser.

    I just accessed the site without any problems thru the google chrome browser.


    Kind regards
    Angela
    I have contacted the domain registry company and this error has now been corrected
  14. #8
  15. Eager to learn
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Jan 2009
    Location
    Maryland, USA
    Posts
    2,230
    Rep Power
    2179
    Relatively simple fix.

    On ".thumbnail:hover" just remove float:left;
    "Quality of responses may vary. I reserve the right to change my mind for any reason what-so-ever without admitting I was wrong. I'd prefer to change your mind however, it's easier on my ego". - jwdonahue

    "so no-one has actually bothered to post an original quote ? what's wrong with making up your own?"
    - marnixR
  16. #9
  17. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    6
    Rep Power
    0
    Hi Eric,

    Thank-you so much for finding my error. It now works in Safari and Chrome

    Kind regards
    Angela

IMN logo majestic logo threadwatch logo seochat tools logo