#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Location
    Fort Collins, CO
    Posts
    287
    Rep Power
    18

    Gap issue with IE7, but not FF3 or Chrome


    Hi,

    Thanks for your time...

    If you visit this site with IE7, http://demo.wp4re.com, you should see a big gap just beneath the main menu and the house photo and blue back gradient background. This looks fine in FF3 and Chrome, so you can see how it's meant to look with either browser.

    Any idea what's causing this?

    PS - The xhtml doesn't validate (2 errors), but it's it's not the issue as I already tried removing the culprits yet it didn't affect the gap. I've since put the code back in.

    Thanks in advance.
  2. #2
  3. CSS & JS/DOM Adept
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jul 2004
    Location
    USA (verifiably)
    Posts
    20,124
    Rep Power
    4309
    It's because of the relative positioning of "#MenuMain". Use "margin-top" instead of "top" (and keep the "position:relative" declaration because it has other uses).

    P.S. Are you aware that Firefox 5 is out?

    Comments on this post

    • JHouse agrees
    Spreading knowledge, one newbie at a time.

    Learn CSS. | PHP includes | HTML Validator | CSS validator

    Remember people spend most of their time on other people's sites (so don't violate web design conventions).
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Location
    Fort Collins, CO
    Posts
    287
    Rep Power
    18
    Kravvitz always coming through...that did the trick, thanks!!!

    I'm using FF5, not FF3 (my mistake).

    Thanks again for your help, as well as the prompt reply.

IMN logo majestic logo threadwatch logo seochat tools logo