#1
  1. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Mar 2008
    Posts
    657
    Rep Power
    38

    Overflow auto doesn't work in opera


    Hi I have the following CSS, which works in everything except the Opera browser.
    Code:
    #bodyRightWhite{
    float:left;
    margin-top:280px;
    float:left;
    position:absolute;
    width:568px;
    height:278px;
    margin-top:274px;
    margin-left:435px;
    padding:12px 12px 12px 12px;
    background-color:#FFFFFF;
    overflow:auto;
    }

    I need to use "overflow:scroll;" to get it to work in Opera, but this creates a horizontal and vertical scroll bar. I only need a vertical scroll bar.

    What is the work around for this?

    thanks
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Oct 2009
    Location
    Nebraska, USA
    Posts
    862
    Rep Power
    275
    Have you even looked at what you have there?
    1. You have float:left; declared twice,
    2. You have margin-top: declared twice with 2 different values,
    3. You are using position:absolute; with float:left; (which do you want to do... position absolutely or float left?),
    4. You are using some huge margin values, telling me there is something wrong there.

    Can you please post a link to the page you are working on with this, so, we may possibly help you get thru this?
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Mar 2008
    Posts
    657
    Rep Power
    38

    thanks Don R


    I just cranked out CSS. I need to go back in and clean it up.
    For some reason, the overflow:auto; is working now. I'm not sure what was up, maybe the sloppy CSS like you suggested.

    thanks
    again!
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Oct 2009
    Location
    Nebraska, USA
    Posts
    862
    Rep Power
    275
    Originally Posted by lelales
    For some reason, the overflow:auto; is working now. I'm not sure what was up, maybe the sloppy CSS like you suggested.
    Glad you got it figured out..and, I agree, that was some sloppy CSS there

IMN logo majestic logo threadwatch logo seochat tools logo