#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2012
    Posts
    24
    Rep Power
    0

    Let's play find the error!


    Morning guys (or it is for me!),

    I've been working on a dummy website to keep my knowledge of HTML and CSS in good order and all has been going fine. However, this morning the index page has stopped displaying the way it should.

    It's a responsive site where under the header its a two column layout, which changes to 1 column when the browser window reduces to the required size.

    This worked fine yesterday but this morning the opposite seems to be happening. It's either a stupid missing html bit or its my CSS but I've tried validating the code and HTML is fine, CSS has some warnings but nothing to indicate why this is happening.

    Any help greatly appreciated as always!

    http://173.254.28.25/~desigog0/web/

    CSS
  2. #2
  3. No Profile Picture
    Permanently Banned
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2013
    Location
    Ludhiana
    Posts
    33
    Rep Power
    0
    the website seems to be opening just fine in smaller browser windows in the single column.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2012
    Posts
    24
    Rep Power
    0
    Firefox and Chrome appear fine in small browser windows, but when expanded, loses structure.

    Safari when in small window, has 2 columns, and then 1 when expanded which is the opposite of what it should do.

    I've never seen this before. I know browsers handle CSS differently but I've never seen this...

    There must be something in my code somewhere? A missing close bracket or something...?

    ----------------------------------------------

    EDIT: Found the issue, missing a closing bracket on my media query for the navigation styles. Quite surprised CSS validator didn't pick that up.

IMN logo majestic logo threadwatch logo seochat tools logo