#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2013
    Posts
    5
    Rep Power
    0

    Responsive Code Only Works on Home Page


    Hey all,

    I have a multi-page site and I'm trying to make it responsive to different screen sizes using @media queries. So far, it's working just fine... on the home page. Every other page just won't do it - I open the site up on my phone and the home page is doing what I want it too, but the others won't. The structure of each page is exactly the same - a navbar, header, right column, left column, and footer, all structured using div tags. I can't think of any reason why these other pages would not work when the home page does. I'd appreciate any pointers you could give me.

    For those interested, this is the website: imd(dot)edumedia(dot)ca/grif0163/mtm4006/final/index(dot)html

    It would be a very, very long post if I quoted all my CSS, so here's a link to the css file itself: imd(dot)edumedia(dot)ca/grif0163/mtm4006/final/styles/style(dot)css
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2013
    Posts
    5
    Rep Power
    0
    Oh, and for the record, I'm still a student learning this, so some of you may be blinded by my horribly inefficient CSS. Apologies in advance
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Oct 2009
    Location
    Nebraska, USA
    Posts
    867
    Rep Power
    275
    you only have the viewport meta tag in your home page source.
    add
    Code:
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    in the head of your other HTML pages.
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2013
    Posts
    5
    Rep Power
    0
    .......

    ......excuse me while I go lobotomize myself with a rusty spoon.

    It's always SOMETHING, isn't it? Thank you very much for checking that out for me, I looked over my HTML a half-dozen times and never caught that.

IMN logo majestic logo threadwatch logo seochat tools logo