#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2005
    Posts
    493
    Rep Power
    65

    WEIRD issue with firefox


    hey all,
    i'm having a really strange issue with firefox users on windows. basically, my site is simple. i've got navigation on the left, and a content table on the right. it's all done with CSS.

    firefox users on windows have been complaining that sometimes (not all the time) the content window has been loading half way. it's beendoing this on numerous PCs with firefox, and i can't figure it out. sometimes it loads the whole content box, sometimes it stops half way.
    it's fine all the time in IE on both platforms, and firefox on a mac.

    here is the code i'm using for the content boxes:

    #content_table { FONT-FAMILY: Verdana, Helvetica; width: 60%; margin: 0 auto; border: 1px solid #999; overflow: hidden; }

    #content_table h2 { FONT-FAMILY: Verdana, Helvetica; margin: 0; -moz-opacity: 1; font-size: 15px; text-align: left; padding: 2px 0 2px 15px; font-weight: bold; background: #000 url(../../../../images2/title.png) repeat-x; color: #fff; border: 1px solid #000 }

    #content_table p { font-size: 12px; FONT-FAMILY: Verdana, Helvetica; -moz-opacity: 1; padding: 5px; background: #333333; color: #FFF; margin: 1px }

    if you're on a PC, check it out:

    link

    thanks!
    Last edited by haid; October 2nd, 2005 at 08:40 PM.
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2005
    Posts
    327
    Rep Power
    20
    Works fine on FF on my PC though its' slow. Validate your code! You have a lot of css errors along with 15 html errors. For example, you cannot use a <p> tag in a <ul>. Only <li> items are allowed.

    In fact, I tried it on IE and it looks horrible!
  4. #3
  5. CSS & JS/DOM Adept
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jul 2004
    Location
    USA (verifiably)
    Posts
    20,124
    Rep Power
    4309
    When I reload the page in Firefox the bug occurs. Please fix your HTML errors.

    If the bug is still present after you fix the errors, I might look into it further.
    Spreading knowledge, one newbie at a time.

    Learn CSS. | PHP includes | HTML Validator | CSS validator

    Remember people spend most of their time on other people's sites (so don't violate web design conventions).
  6. #4
  7. It
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Sep 2003
    Location
    UK
    Posts
    1,222
    Rep Power
    372
    I have experienced similar oddness with sites of varying levels of standards compliance. I believe it is a Firefox rendering issue, but I obviously agree that you should validate your code before blaming any browser.

    The issue I discovered was caused by using overflow: hidden on a table, which you are doing on your page. See the thread I started on this for a reduced (standards compliant) test case and more ideas about the bug. It seems to already be fixed in Deer Park, so this problem should go away before too long.

IMN logo majestic logo threadwatch logo seochat tools logo