#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2013
    Posts
    5
    Rep Power
    0

    Issue with images used as links


    I am having trouble with my facebook and twitter buttons on my wordpress web page. These buttons are part of a wordpress menu that appears on the upper right-hand corner of my web page which I am not allowed to tell you the URL of, but if you email me I can do so

    The problem is that the cursor only changes to allow clicking the buttons when it is positioned over the top edge or bottom edge of the button. This happens with both Firefox and Internet Explorer. If you have seen this behavior before I would like to hear from you. It must be something that has happened before!

    To debug this, I made a page on the site that tries to duplicate as much as possible of the css behind the buttons. Done this way, the buttons function properly and do not have the problem I am complaining of. So I am stumped about how to proceed, unless someone can give me a clue based on the symtom I mentioned.

    Thank you for any help you can provide!

    Bill Rowan
  2. #2
  3. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2011
    Location
    The Pleiades
    Posts
    299
    Rep Power
    9
    If you can't provide a link, can you at least provide your HTML and CSS?

    Regards,

    NM.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2013
    Posts
    5
    Rep Power
    0
    Please bear with me - I need to post 5 times before I can provide a URL. I need to figure out some way to provide the css too, it is a largish file.
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2013
    Posts
    5
    Rep Power
    0
    You see, the reason I am not allowed to provide the URL is because I am a new user. Once I post five times, I can do that.
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2013
    Posts
    5
    Rep Power
    0
    Let's see if the URL can go in now:

    www.originalgiovanni.com/experiments

    Note that in the upper right corner, there is the problem with the two buttons on the right. In the middle of the page, the buttons work.

    Bill
  10. #6
  11. CSS & JS/DOM Adept
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jul 2004
    Location
    USA (verifiably)
    Posts
    20,128
    Rep Power
    4304
    You see, the reason I am not allowed to provide the URL is because I am a new user. Once I post five times, I can do that.
    So making pointless comments is better than trying to circumvent the automated URL filter? You clearly have not read the CSS Forum Posting Guidelines. (It seems most people don't notice that thread without help. )

    When posting code, please place it between [code][/code] tags. If you want to use the button to add the tags, paste the code in the textarea and then select it before clicking the button (so you don't get the problematic JavaScript prompt dialog). Fortunately though, this forum is scheduled for a very badly needed upgrade.

    P.S. Welcome to DevShed Forums, whrowan.
    Spreading knowledge, one newbie at a time.

    Check out my blog. | Learn CSS. | PHP includes | X/HTML Validator | CSS validator | Common CSS Mistakes | Common JS Mistakes

    Remember people spend most of their time on other people's sites (so don't violate web design conventions).
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Dec 2003
    Posts
    710
    Rep Power
    441
    Believe it or not, your #giovannis-menu is on top of those buttons and blocking you from clicking them. The easiest fix would be to add a z-index to #menu_social:

    Code:
    #menu_social {z-index: 100}
  14. #8
  15. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2013
    Posts
    5
    Rep Power
    0

    problem solved


    rdoyle720's solution worked - problem solved. Thank you so much.

IMN logo majestic logo threadwatch logo seochat tools logo