#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2013
    Posts
    2
    Rep Power
    0

    Need help cross browser problem


    Hi,

    I'm working with setting up a site using css and php. My problem is that the Menubar looks correct in IE and FF, but craps out in Chrome, Opera and Safari. I don't see the error in the code. If you want to look at my code you can d/l the folder from Mediafire -- contact me for a link to Mediafire

    Thanks
    Last edited by stevekalin; August 21st, 2013 at 01:56 PM. Reason: spelling
  2. #2
  3. CSS & JS/DOM Adept
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jul 2004
    Location
    USA (verifiably)
    Posts
    20,126
    Rep Power
    4304
    Welcome to DevShed Forums, Steve.

    Have you made sure that your code is valid and that you haven't forgotten any vendor prefixes for CSS3 properties you're using? The first step in debugging should always be making sure that your code is valid (in order to rule out any errors as the cause for the problem).
    http://validator.w3.org/
    http://jigsaw.w3.org/css-validator/ (Under "more options", make sure the "Profile" is set to "CSS level 3" and set "Vendor Extensions" to "Warnings".)

    New members have an initial probation period where they aren't allowed to send PMs (until they have made 10 posts).

    As you (may have) found out new users are restricted from posting URLs until they have made 5 posts. You may need to get around this by leaving out the "http://" and putting a space before each ".". Yes this rule is annoying, but the administrators say it's necessary for limiting spam.
    Spreading knowledge, one newbie at a time.

    Check out my blog. | Learn CSS. | PHP includes | X/HTML Validator | CSS validator | Common CSS Mistakes | Common JS Mistakes

    Remember people spend most of their time on other people's sites (so don't violate web design conventions).
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2013
    Posts
    2
    Rep Power
    0

    cross browser


    Hello Kravvitz,

    I'm working on my localhost until I debug it. I am validating at 4.01 Strict.

    Try this: "www" "mediafire" "com" "/folder/ipbq3psjpz5sp/testing"

    Thanks Steve

IMN logo majestic logo threadwatch logo seochat tools logo