#1
  1. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2002
    Posts
    123
    Rep Power
    15

    'server has not yet been opened' Crystal Reports error [RESOLVED]


    Hi,
    I'm trying to open a form with the report viewer control on it to view a report.
    The report data is set using the SetDataSource method:
    rptCourses.Database.SetDataSource rst, 3

    The report's viewing form Load event is:
    CRViewer1.ReportSource = rptCourses
    CRViewer1.ViewReport

    I get a 'server has not yet been opened' error when trying to execute the 'CRViewer1.ViewReport' statement.

    I have another report in the same project (not using SetDataSource) that runs just fine, and a report on another project that does use SetDataSource that uses more or less the same code and runs fine.

    I'm using VB6 and CR 8.5 on winXP machine

    Any ideas? Help would be appreciated.
    thanx
    Last edited by shafan; July 10th, 2003 at 03:15 AM.
  2. #2
  3. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2003
    Location
    Aurangabad, MS, India
    Posts
    1
    Rep Power
    0
    Hi,

    I am also having same problem, I am using ODBC to connect to SQL Server Database, In same application my one report get open fine, but two reports give this error.

    Please help me.

  4. #3
  5. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2002
    Posts
    123
    Rep Power
    15
    make sure the recordset you pass to the report contains exactly the same fields as the one the report was based upon (that was my problem - I missed a field)
  6. #4
  7. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Posts
    1
    Rep Power
    0
    I have found that the only way to get round this problem with secured databases is to specifically set the logon info for the table
    e.g.

    Report.database.tables(1).setlogoninfo "", "", "UserName", "Password"

    For more info see
    http://support.crystaldecisions.com/...nvironment.pdf
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2007
    Posts
    3
    Rep Power
    0
    I Have the same problem with my report :
    using Crystal 8.5
    Here's my answer for this problem :

    In VB6 I make a program that call my report using an ODBC.

    But on the computer where I install my program, the ODBC - System DSN was NOT install.

    So I create a System DSN on the user machine, and everything goes fine after.
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2008
    Posts
    2
    Rep Power
    0

    Angry Crystal Report 8.5


    Hi,
    I'm trying to open a form with the report viewer control on it to view a report.

    CRViewer1.ViewReport

    When I am opening the report file from VB its working
    nicely, the data is coming in the report but in the report window when I try to refresh it,
    I get a 'server has not yet been opened' error.

    I have tried to refresh the report file form its own crystal report file .rpt, there its working. The is getting refreshed but the problem comes with refreshing at the runtime in VB6.


    I'm using VB6 and CR 8.5 on winXP machine

    Any ideas? Help would be appreciated.
    thanx

    Waiting for reply.........
    Abhijeet
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2007
    Posts
    3
    Rep Power
    0

    Try this


    Originally Posted by abhijeet471496
    Hi,
    I'm trying to open a form with the report viewer control on it to view a report.

    CRViewer1.ViewReport

    When I am opening the report file from VB its working
    nicely, the data is coming in the report but in the report window when I try to refresh it,
    I get a 'server has not yet been opened' error.

    I have tried to refresh the report file form its own crystal report file .rpt, there its working. The is getting refreshed but the problem comes with refreshing at the runtime in VB6.


    I'm using VB6 and CR 8.5 on winXP machine

    Any ideas? Help would be appreciated.
    thanx

    Waiting for reply.........
    Abhijeet
    ************ SOLUTION *************
    When I read your problem, I think this :
    It seems that your report was create and save with this option :
    SAVE DATA WITH REPORT
    Try to save your report without saving Data with report.
    Now you will have only the error : 'server has not yet been opened' (I SUPPOSED).

    If you have create your report with a DSN connection, try to create this connection on the computer you try to open the report.
  14. #8
  15. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2008
    Posts
    2
    Rep Power
    0

    Crystal Report 8.5


    Originally Posted by baronming
    ************ SOLUTION *************
    When I read your problem, I think this :
    It seems that your report was create and save with this option :
    SAVE DATA WITH REPORT
    Try to save your report without saving Data with report.
    Now you will have only the error : 'server has not yet been opened' (I SUPPOSED).

    If you have create your report with a DSN connection, try to create this connection on the computer you try to open the report.
    Hello
    Will you please explain that:
    What is this option:
    'SAVE DATA WITH REPORT'

    I have used ODBC connection to connect the report, not DSN connection.


    ------------
    Abhijeet
  16. #9
  17. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2007
    Posts
    3
    Rep Power
    0
    [QUOTE=abhijeet471496]Hello
    Will you please explain that:
    What is this option:
    'SAVE DATA WITH REPORT'

    I have used ODBC connection to connect the report, not DSN connection.


    The Option "Save Data with Report" is an option in Crystal Report.
    When you create your report with Crystal Report when you click FILE in the m,enu taskbar, you see a sub menu with : new , open, close, etc... you will see Save as... And under this you will see : 'SAVE DATA WITH REPORT' , unchecked this option when you save your report.
  18. #10
  19. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2009
    Posts
    1
    Rep Power
    0

    CRAXDRT:2147192184 Server has not yet been opened


    Hello...
    I've the same problem.I'm using Oracle OLE DB database and asp classic.. my report's charts graphs are working quite fine.. but whenever i tried to refresh this report in web browser or asp page.. found this error...

IMN logo majestic logo threadwatch logo seochat tools logo