#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2004
    Posts
    50
    Rep Power
    10

    URGENT HELP - Delphi app crashed!!!


    Hi,


    Why I am getting my Delphi application crashed before it's loaded?!!! the same application was working before and it's still working on other computers..


    I am getting this error:

    <?xml version="1.0" encoding="UTF-16"?>
    <DATABASE>
    <EXE NAME="ezilife.exe" FILTER="GRABMI_FILTER_PRIVACY">
    <MATCHING_FILE NAME="ezilife.exe" SIZE="1413632" CHECKSUM="0x60EDD770" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="06/19/1992 22:22:17" UPTO_LINK_DATE="06/19/1992 22:22:17" />
    </EXE>
    <EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
    <MATCHING_FILE NAME="KERNEL32.DLL" SIZE="930304" CHECKSUM="0xCBCCF8A9" BIN_FILE_VERSION="5.1.2600.1106" BIN_PRODUCT_VERSION="5.1.2600.1106" PRODUCT_VERSION="5.1.2600.1106" FILE_DESCRIPTION="Windows NT BASE API Client DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows® Operating System" FILE_VERSION="5.1.2600.1106 (xpsp1.020828-1920)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xE7ED3" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.1106" UPTO_BIN_PRODUCT_VERSION="5.1.2600.1106" LINK_DATE="08/29/2002 10:40:40" UPTO_LINK_DATE="08/29/2002 10:40:40" VER_LANGUAGE="English (United States) [0x409]" />
    </EXE>
    <EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
    <MATCHING_FILE NAME="KERNEL32.DLL" SIZE="930304" CHECKSUM="0xCBCCF8A9" BIN_FILE_VERSION="5.1.2600.1106" BIN_PRODUCT_VERSION="5.1.2600.1106" PRODUCT_VERSION="5.1.2600.1106" FILE_DESCRIPTION="Windows NT BASE API Client DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows® Operating System" FILE_VERSION="5.1.2600.1106 (xpsp1.020828-1920)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xE7ED3" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.1106" UPTO_BIN_PRODUCT_VERSION="5.1.2600.1106" LINK_DATE="08/29/2002 10:40:40" UPTO_LINK_DATE="08/29/2002 10:40:40" VER_LANGUAGE="English (United States) [0x409]" />
    </EXE>
    </DATABASE>
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2004
    Posts
    50
    Rep Power
    10
    Please Help!!
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2004
    Posts
    50
    Rep Power
    10

    URGENT help please


    can anyone help please.. I am still awaiting for a reply...
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2004
    Posts
    4
    Rep Power
    0

    info needed


    1) OS different on other pc?
    2) dll/ocx used in your app?
    3) put debug messages eg..
    showmessage('ok till line ## in create');
    try get the line that cause the error.
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2004
    Posts
    50
    Rep Power
    10
    Hi,

    OS is Windows XP in both PCs and there is nothing in the create routine other than reading an image path from the registry. As I said before the same application is working on all other PCs which have the OS and configurations.


    Can I have your email address to send you the code?


    Many Thanks,
    Jassim Rahma
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2004
    Posts
    50
    Rep Power
    10
    I hope I am not disturbing you but it's URGENT case..



    thanks..





    Originally Posted by jrahma
    Hi,

    OS is Windows XP in both PCs and there is nothing in the create routine other than reading an image path from the registry. As I said before the same application is working on all other PCs which have the OS and configurations.


    Can I have your email address to send you the code?


    Many Thanks,
    Jassim Rahma
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    27
    Rep Power
    0
    try commenting out things until you get it working, or maybe use try...except? And, if this advice is helpful to anyone, please consider answering my post here: http://forums.devshed.com/t213544/s.html
  14. #8
  15. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2004
    Posts
    93
    Rep Power
    10
    You can try delete *.dsk and *.tds files. These are desktop and symbol file that loads with Delphi.

IMN logo majestic logo threadwatch logo seochat tools logo