1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2010
    Rep Power

    Win10 & Delphi 2005

    I was using Win7 with Delphi 2005, and it worked ok, except the help system links didn't work.

    I upgraded to Win10 and everything was the same. I managed to damage my Delphi 2005, while
    trying to write my first property editor, so I did a complete reinstall of Delphi. Nothing worked.
    With help from Embarcadero, I found out I should run as administrator to install. Looked good at
    first, but to test it, I tried compiling some of the demo programs. They appeared to compile fine
    but did not open in the debugger. The running icon is lit, but the step into, over, etc. buttons are
    greyed out. I stopped the debugger and looked for the compiled program. It's there and runs
    outside of the IDE just fine.

    The last 2 line of the compile event log are:
    Module Load: UNKNOWN_MODULE_2. No Debug Info. Base Address:
    $642D0000. Process Project5.exe (9652)
    First chance exception at $00000000. Exception class $C0000005
    with message 'access violation at 0x00000000: read of
    address 0x00000000'. Process Project5.exe (9652)

    These are the same for any program that I compile, except the number after UNKNOWN_
    MODULE_ may change.

    The other change is that the F1 key worked for anything in the Reference ->VCL for Win32 section
    of the help files, and the links within that section, in the Windows Document Explorer work fine.
    None of the other help section links work...

    Any ideas how to fix these problems?
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2014
    Rep Power
    You can try to find answer for your question at the next article: Microsoft BUILD, Windows 10, and Delphi and C++Builder

IMN logo majestic logo threadwatch logo seochat tools logo