#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2001
    Posts
    48
    Rep Power
    18

    Can't mount CD-ROM on FreeBSD box


    Hi,

    I figured freebsd could answer this one (if freebsd can't then I'm really in trouble!).

    I just installed FreeBSD on another box, and for the first time I'm trying to mount the CD-ROM so I can transfer some files.

    It's a Pioneer CD-ROM and the server was actually built way back in 1999. Anywho, I installed the FreeBSD OS and everything seems to work just dandy.

    I checked /etc/fstab and found this line (amongst others):

    /dev/acd0c /cdrom cd9660 ro, noauto

    So, as root, I typed the following to try to mount the beast (ahem, sorry for that phrase):

    # mount -t cd9660 /dev/cd0c /cdrom

    I get the following message:

    cd9660: /dev/cd0c: Device not configured

    The CD-ROM is one of those non-tray versions and so it doesn't spin-up when you feed it a CD. I'd give you the model number, but I can't for the life of me remember the name of the file that stores the device probe results from the bootstrap procedure.

    [UPDATE 1: It's a Pioneer Model DR-A02S and it's IDE/ATAPI. It's listed in the CMOS as the IDE Sec. Slave: CDROM, Mode 4, if that helps].

    [UPDATE 2: The bootstrap message file is /var/run/dmesg.boot].

    There's a SCSI tape device in the server, so I checked my kernel config and it does have the 15 second delay option line for SCSI devices.

    If you, freebsd, or anyone else can lend any insights, I'd love to hear 'em!

    Oh, and yes, the CD is in the drive!
    Last edited by DH123; September 21st, 2001 at 10:24 AM.
  2. #2
  3. Wiking
    Devshed Expert (3500 - 3999 posts)

    Join Date
    Sep 2000
    Location
    Sweden
    Posts
    3,608
    Rep Power
    27
    And you can't just run #mount /cdrom?

    BTW, The line in fstab says
    /dev/acd0c /cdrom cd9660 ro, noauto

    And you're trying to mount
    /dev/cd0c

    Not the same...

    And shouldn't it be iso9660, not cd9660?

    /NoXcuz
    UN*X is sexy!
    who | grep -i blonde | date; cd ~; unzip; touch; strip; finger; mount; gasp; yes; uptime; umount; sleep
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2001
    Posts
    48
    Rep Power
    18
    NoXcuz,

    I tried your suggestion:

    #mount /cdrom

    And got this message:

    cd9660: /dev/acd0c: Invalid Argument

    And yes, that cd0c vs. acd0c had me scratching my head too but all the info in the FreeBSD handbook and the stuff I found through Google searches always referred to cd0c without the preceding letter a.

    Some very weird voodoo going on now too. After I installed the OS and rebooted everything seemed find. I've just rebooted again and now the bootstap message is giving me a notice that the entire /etc/fstab device listing failed.

    I think I'll re-install . . .
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2001
    Posts
    48
    Rep Power
    18
    I reinstalled and still have the same problem. I ran this command:

    #camcontrol devlist -v

    And received a listing which included my SCSI tape drive but no CD-ROM device.

    Then I ran this command:

    #cdcontrol info

    And got this message:

    cdcontrol: no CD device name specified, defalting to /dev/cd0c
    cdcontrol: no disc in drive /dev/cd0c


    There was indeed a CD in the drive!

    Hmmmm? Why do it not seem my CD-ROM?

    I've been searching the Google Groups and this seems to be a very common problem but definitive answers are few and far between.

    [rant] Ack! I hate this! Wasting days of time just to read the contents of a frikkin' CD! Bill G. can sleep soundly knowing this is still a major problem with Unix OS's.[/rant]
    Last edited by DH123; September 21st, 2001 at 10:47 AM.
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2001
    Posts
    48
    Rep Power
    18
    I'm so ashamed . . .

    Time is money so I re-installed RedHat Linux 7.0 on the box and the CD-ROM mounted with no problems.

    Ah . . . life is full of little setbacks like this. I guess my FreeBSD-only lifestyle will have to be postponed for a while.
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2001
    Posts
    48
    Rep Power
    18
    The saga continues . . .

    Although the CD-ROM was mountable using Red Hat Linux, it wouldn't read for long. When I tried to copy all the files from the CD-ROM recursively (all directories and subdirectories at once), it would work for a bit and then I get error messages on the command line such as "hdc: blah blah blah."

    I went to Google groups and did a search. Again, lots of people seem to encounter similar problems but answers are not all that forthcoming.

    I then tried to copy one directory at a time, and guess what . . . it worked! It worked, that is, until I got a disk full error message. Disk full?!?? This computer was old, but not that old. The hard drive has 4 GB of space and I only used a smidgen of that for Red Hat's entire install.

    I ran a df command and lo and behold . . . my /var partition was only 256 MB in size. The CD-ROM was had 650 MB of stuff on it, so d'uh! So, not enough room in the partition . . . why wouldn't the OS just say so when I was doing the recursive copy instead of all that arcane mumbo jumbo stuff that sent me off on a wild goose chase looking for answers.

    So, I re-installed the OS and manually partitioned the drive so /var would have 1000 MB (1 GB). Off I went again to copy everything using a recursive cp from the CD-ROM to the /var directory. Plenty o' space, yep . . . this'll be easy. Wrong! I got the same hdc: blah blah blah errors again. Something about that old CD-ROM that just doesn't like talking to the OS unless it's installing it.

    Finally, some oxygen managed to seep into my brain and I thought, "bugger it, I'll just FTP all these files from my Windows box into this Linux box." I did this, took about twenty minutes to move the entire 650 MB and now all is well.

    Why am I telling you all this? Well, if you are still reading this, I'm writing this down because I wasted 2 days being stubborn about that CD-ROM drive not working. I failed to stop and consider my options. I just got tunnel vision and wouldn't let that problem of the CD-ROM go.

    Thus endeth the lesson . . .

    P.S. Now that I've just decided to FTP everything into this old box, I'm blowing off Red Hat and going back to FreeBSD. (and there was much rejoicing).
    Last edited by DH123; September 22nd, 2001 at 09:32 PM.

IMN logo majestic logo threadwatch logo seochat tools logo